WoW Installer reads: "Failed to read information from the internet". Any help please?

Discussion in 'Mac Basics and Help' started by killswitch1698, Apr 2, 2010.

  1. killswitch1698 macrumors regular

    Joined:
    Jun 9, 2009
    #1
    Hello :)

    I've been playing WoW for 5 years and have never had a single problem like this on my mac before, but all of a sudden when I try to Install WoW-WOTLK
    (World of Warcraft for those who don't know) with the Installer client I downloaded, the program takes 5 minutes for the installation window to pop up, and then ANOTHER 5 minutes later an error window pops up saying: "Failed to read information from the information from the internet. Please close all applications and try again". (I didn't have any other apps opened up)

    I have used this method of downloading the client for the past 6 times I have reinstalled it and have had success.

    In an attempt to make the client install without error, I have tried:

    -Disabling my Firewall
    -Restarting my iMac
    -Reinstalling the client
    -Even changing wireless networks

    None of the above worked at all.

    I am the admin account so that obviously isn't the problem either.

    Please don't mention google or any other websites in this thread;

    1. Because I want expert advice
    2. This is starting to look like a specific issue

    Also I heard that security programs can interfere with this. What do you think might be messing around with this?

    Many thanks,

    -Devin
     
  2. miles01110 macrumors Core

    miles01110

    Joined:
    Jul 24, 2006
    Location:
    The Ivory Tower (I'm not coming down)
    #2
    Probably a security program. Do you have Little Snitch installed? Are the proper ports forwarded in your router? Any background processes at all running that might interfere?
     
  3. killswitch1698 thread starter macrumors regular

    Joined:
    Jun 9, 2009
    #3
    Nope I don't have little snitch on my mac. And what do you mean by background processes? If you mean any other applications then no.
     
  4. CubeHacker macrumors 65816

    CubeHacker

    Joined:
    Apr 22, 2003
    #4
    Its possible that the WoW servers are down. However, you would probably get a better response by asking this in the Blizzard Mac Help Forums.
     
  5. killswitch1698 thread starter macrumors regular

    Joined:
    Jun 9, 2009
    #5
    Yeah that seems very probable since a forum I previously checked was posted march 26th. Must be an issue with everyone trying to reinstall it.

    And I would ask world of warcraft, but I play on a private server.
     
  6. killswitch1698 thread starter macrumors regular

    Joined:
    Jun 9, 2009
    #6
    It's been a month since I haven't been able to use this client. Can someone please help me out here? It's starting to seem like it's my mac's fault.
     
  7. CubeHacker macrumors 65816

    CubeHacker

    Joined:
    Apr 22, 2003
    #7
    Perhaps you should try reinstalling from the installation CD instead of the downloaded client.
     
  8. dr.holliday macrumors newbie

    Joined:
    Oct 31, 2009
    #8
    Same

    I have the same problem, except I can't install basic WOW using the installer/downloader. I've tried what the various forums suggest but it doesn't work. Sigh.
     
  9. dr.holliday macrumors newbie

    Joined:
    Oct 31, 2009
    #9
    Resolved

    Hey - The problem is solved. Just do the steps below. I actually had to do everything twice in a row, but once I completed the second repair permissions the installer took off with no problem.

    If you have modified the hosts file change it back to the default.


    Please use the steps below to repair file permission settings on the hard drive.
    1.) Click on the Finder icon in the Dock
    2.) Open the Applications folder
    3.) Open the Utilities folder
    4.) Double click on the Disk Utility application icon
    5.) Select the hard drive the game is installed on
    6.) Select the First Aid option
    7.) Click on the Repair Disk Permissions button

    Repair Directory Procedure:
    1. (Re) start the computer
    2. Right after the computer starts press Cmd (Apple) +s until you get a black screen with white type
    3. Let go of the keys when this screen comes up
    4. At the cursor please type the following: fsck -fy and press return
    5. Please be aware that some of the procedures will look like they are frozen, but are actually taking a long time i.e. checking hierarchy
    6. If anything had to be repaired, repeat step 4
    7. Once things are repaired type exit and press return
    8. Computer will boot into Mac OS
     
  10. Sun Baked macrumors G5

    Sun Baked

    Joined:
    May 19, 2002
    #10
    Also the wrath has a rather long video that it is downloading (seems like a download instead of a stream) so the screen stays black for a long long time before it starts the first time.
     

Share This Page