WoW Keeps Crashing

Discussion in 'Mac and PC Games' started by virgomac, May 30, 2009.

  1. virgomac macrumors member

    Joined:
    Mar 10, 2008
    #1
    I have yet to have any problems with this laptop until now, decided to give WoW a go again, and loaded it up. Since then I have had it crash at least several times a night, or even worse freeze the computer or force a restart.

    I've tried scanning , re-patching, everything short of a reinstall of it.

    Any of you had problems like this and found a solution?
     
  2. GoCubsGo macrumors Nehalem

    GoCubsGo

    Joined:
    Feb 19, 2005
    #2
    Count your blessings?


    Ok sorry, repair permissions and see what happens.
     
  3. rdowns macrumors Penryn

    rdowns

    Joined:
    Jul 11, 2003
    #3
    Open up console.app and see what's causing the crashes. Post your log here.
     
  4. Randman macrumors 65816

    Randman

    Joined:
    Jul 28, 2008
    Location:
    Jacksonville, Fla
  5. merc669 macrumors 6502

    merc669

    Joined:
    Jun 7, 2006
    Location:
    Southern MD, USA
    #5
    Try running Onyx and let it do some clean-up and repair permissions. I run WOW on my first gen MBP with no issues. Also how are your graphics set. Maybe they are too high and need to be brought down some. At least follow what the others are saying and repair the permissions and check the output of the console to see what caused the crash. Also, when WOW crashes it would normally generate a Crash Report that it wants to send to Apple. You can review that there also.

    Bill.....:apple:
     
  6. Plutonius macrumors 603

    Plutonius

    Joined:
    Feb 22, 2003
    Location:
    New Hampshire
    #6
    The tech forums at www.worldofwarcraft.com are actually pretty good. If you post your problem there, someone usually replies fairly quickly.
     
  7. Josh Kahane macrumors 6502

    Joined:
    Aug 29, 2006
    Location:
    Suffolk, UK
    #7
    Delete the WTF and Interface folder in your WoW directory, (but back them up first) and then run WoW. If it runs fine, just change your settings back to what you want in the menu, and then put the addons back into your Interface/Addons/ folder and make sure they are all up to date.

    You can use WoW Matrix, a great app for macs that automatically updates all of your WoW addons.

    After this before loading a character, select the addons button in the corner and make sure the 'Load Out-Of-Date Addons' box is ticked. Then hope it works for you.
     

Share This Page