WoW locks up my Mac

Discussion in 'Mac and PC Games' started by SolidSnake90, Oct 21, 2009.

  1. SolidSnake90 macrumors newbie

    SolidSnake90

    Joined:
    Oct 21, 2009
    Location:
    Windsor
    #1
    Everytime I log into WoW everything runs pretty smooth for a while but after a while my internet connection goes in and out my latency hits >2000 and my iTunes locks up and starts skipping, it doesn't happen with any other app and it's starting to really frustrate me any advice?
     
  2. travisjacques macrumors member

    Joined:
    May 12, 2009
    #2
    How much ram do you have and which video card is it?
     
  3. Peace macrumors Core

    Peace

    Joined:
    Apr 1, 2005
    Location:
    Space--The ONLY Frontier
    #3
    It's the WoW app itself. I have a dual-quad Mac Pro with 12GB RAM and a GTX-285 or GT-120 video card and it still hangs sometimes.

    I'm hoping when Blizzard comes out with the new version it might fix some of the problems.
     
  4. TheChemist macrumors regular

    TheChemist

    Joined:
    Sep 25, 2006
    #4
    That's happened to me a few times, the solution is to delete the Cache folder from WoW.

    At least that's what works for me.
     
  5. apfhex macrumors 68030

    apfhex

    Joined:
    Aug 8, 2006
    Location:
    Northern California
    #5
    By any other app do you mean other intensive 3D games too? Because this sounds exactly like what happens when the video card overheats and crashes the system.
     
  6. SolidSnake90 thread starter macrumors newbie

    SolidSnake90

    Joined:
    Oct 21, 2009
    Location:
    Windsor
    #6
    No it's not the video card, I've run it for almost a year and a half now. I noticed that my airport shuts off and turns back on causing it to lock up, I don't know what to do to fix it :confused:
     

Share This Page