WOW, patch 3.3 has some serious OpenGL problems

Discussion in 'Mac and PC Games' started by Shivetya, Dec 10, 2009.

  1. Shivetya macrumors 65816

    Jan 16, 2008
    blizzard implemented a new OpenGL system in WOW and its broke. My i5's performance is hideous compared to before. In some cases being out in the open is so slow as to be MS Paint.

    They know it, even their forum CSRs note it happens to their macs too.
  2. juliancs macrumors 6502

    Aug 24, 2006
    Will be worth it in the end. They will have a fix very, very soon. Blizzard likes their mac gamers!
  3. Sambo110 macrumors 68000

    Mar 12, 2007
    Will this actually improve the frame rate in the end? I really hope so.
  4. Cabbit macrumors 68020


    Jan 30, 2006
    I believe they re wrote the openGL engine for WoW mac. I don't know into how much detail they went into this but i suspect it is the ground work for Cataclysm.
  5. Fnord macrumors member


    Aug 12, 2005
    You can tell WoW to use the old Open GL engine by editing the file and adding:

    SET gxapi "OpenGL"

    Found this fix on the Mac WoW Technical Support Forum. Tested it and it works. The file is found in the 'WTF' folder in 'World of Warcraft' folder.
  6. voyagerd macrumors 65816


    Jun 30, 2002
    Rancho Cordova, CA
    What's the new gxapi called?
  7. junior77 macrumors regular

    Jun 29, 2007
    Are you sure it's the openGL causing all your issues and not Blizzards servers? Due to the fact that the servers have been hit quite heavily with more people logging on all at once. Give it a week and see how the performance is with 'less' ppl.
  8. auscraig macrumors newbie

    Dec 12, 2009
    Oh good I thought it was just me!...not that it's good that others have the same problems I do since updating to the latest patch...but it's nice to know I'm not the only one.

    I have a iMac 24" that's only a few months old with 2.93Ghz Chip the 512MB ATI Radeon HD 4850 Graphics card and immediately after the update it's been shocking. The graphics are slow and often frame grab and stutter... etc... the same is happening on my late 2008 15'' Unibody MacBook Pro with the dedicated nVidia graphics...before the patch it was fine to run both computers on full graphics settings.

    It's all the and night... no matter when I log in, so I'm not sure if it's their servers or not. Around Delaran it's always a bit dodgy, but that seems to affect everyone sometimes especially when it's busy... but since the update the whole game is running like a real old dog!

    I've just had a friend apply the WOW patch and he has a 13" MacBook unibody (just before they changed them to MBP's) and he has described it as 'barely playable') as the has no separate graphics card on that model laptop.

    Hope Blizzard fix it soon... as it's annoying to play like it is at the moment! :confused:
  9. Rugbee79 macrumors newbie

    Jun 4, 2008
    London, UK
    I have the same spec iMac as Auscraig and the same effects/problems when playing WoW, to the point where i haven't even tried playing any of the new content as I don't think it is worth it as it would that frustrating to play!

    So for the mean time I happy to arse around in the BG's and grind for rep/money/mats... but only until next weekend me thinks... :rolleyes:
  10. Plutonius macrumors 604


    Feb 22, 2003
    New Hampshire, USA
    The SET gxapi "OpenGL" fix stated above worked great and eliminated any problems caused by the patch.
  11. JaHull macrumors member

    Apr 18, 2009
    I am running WOW with 3.3 patch and the new OpenGL backend enabled with no drop in frame rate, the game is very playable running around 20-30fps which is normal since i have all video options on highest apart from view distance which is at half. The fps may drop to around 15 in dalaran since its a high populated area but this is what happened before the patch as well i am running on OSX 10.5.8 on a 13" MacBook Pro 2.53GHz. Maybe it could be something to do with snow leopard in conjunction with the new OpenGL which is causing the problems
  12. mlprice macrumors newbie

    Dec 12, 2009
    Temporary fix for most OpenGL problems according to Blizzard:

    We plan to release a patch that will address these issues within a week's time (possibly sooner) . In the meantime, you can avoid these issues by following these steps:;

    1) Close the WoW application
    2) Navigate to your main World of Warcraft folder
    3) Open the file in your WTF folder using TextEdit
    4) Add the following line to the bottom of the file: SET gxapi "OpenGL"
    5) Save and Close
    6) Restart WoW

    You can verify that you are using the old OpenGL backend by looking at the minimize/yellow button in window mode. If it's grey then you are using the old backend and the fix above worked.

    We want to apologize once again for the the inconvenience these issues have caused you. We do value your continued support and appreciate you hanging in there with us over the past few days.
  13. Sayer macrumors 6502a


    Jan 4, 2002
    Austin, TX
    That bit about the yellow control being disabled on the "old" OpenGL engine is interesting (to me).

    Sounds like they switched from the older Carbon to Cocoa for the user-facing stuff maybe?

    Looking at the nibs, seems they have done something like this. Interesting.
  14. DMJG macrumors newbie

    Mar 11, 2008
    Me too. I was experiencing lots of video stalls, but going back to the prior OpenGl restored peppy and smooth performance.

    For the record, this is on a Mac Pro running Leopard with a 4870 card.
  15. Kiawos macrumors newbie

    Dec 17, 2009
    cant seem to get it to work

    Ok maybe im stupid but i cant seem to get the workaround to work. Ive edited the file and saved it and everything but my minimize button is still yellow and no perfrmance change. Only thing different was when i signed on it made me accept the user agreement stuff over again. Any ideas?
  16. wirednjx macrumors newbie

    Dec 19, 2009
    Apply the edit midgame it defaults back

    Ive edited the .wtf and within a few min it is back to the old setting. Open .wtf back up and edit is not there.
  17. CenerianStin macrumors newbie

    Dec 21, 2009
    I was having the exact same issue with very low fr, even in IF where I haven't had any problems since upgrading my video card on my MacPro some time back. It was the worst when flying and I would turn- rate would drop to single digits.

    All better now!!! Thanks for the help.

    And to wirednjx, I just added the line to the bottom and saved. Worked first try.
  18. wirednjx macrumors newbie

    Dec 19, 2009
    file edit gets removed mid game

    still have the same problem where the .wtf is getting updated removing the edit. SET gxapi "OpenGL" any recommendations?
  19. Surklyn macrumors regular

    Apr 12, 2009
    hmm.. my i5 runs WoW fine. I'm not sure what people consider low frame rates, as I'm not a hardcore gamer.. but I've been receiving 60fps on max settings at native res?? However, before I updated to 3.3 I tried max settings and the screen went blank (no picture) and I couldn't restore the settings.
  20. theARNSKI macrumors regular

    May 27, 2009
    Sooooo pleased to find this thread. I thought it was just me.

    I just reactivated my account after freezing it to focus on school and finals and I was pretty scared last night noticing how laggy 3.3 made me, it was almost as if I was playing on my old Acer laptop. I thought it was all the new apps I've downloaded onto my Macbook since then.

    I'll be trying that fix later when I get home and hope all goes well.
  21. Blazer24K macrumors member


    Jan 2, 2009
    Birmingham, AL

    Does anyone know if the official "fix" has been made yet, or do we still have to use this workaround?
  22. thejadedmonkey macrumors 604


    May 28, 2005
    I can't say anything about the frame rate, but it makes the computer run so much cooler!

    I just came back from a WoW hiatus and had to redownload the client. I can't say what the performance is like compared to before, since I lost all my graphics settings, but unlike 3.2 and earlier, it doesn't make my MBP sound like an airplane, and actually runs (almost) as cool as in Windows.

    unlike everyone else who posted though, I have a MBP with an ATI graphics card, so that might make a big difference.
  23. crunkplug macrumors newbie

    Jan 13, 2010
    I think that's it folks.

    Up until last week, I was consistently running mid-high video settings at +30fps - only down from max so I can tolerate Dalaran. Even in post-patch mania, my framerate was reliably smooth (on pre-10.6 base 24in 2007 iMac).

    Then, I installed Snow Leopard, and things became very, very BAD in the world (of Warcraft) O_O. Even at lowest settings it's a sluggish crawl at best to get from point A to point B in dalaran, and at any moment elsewhere I get slammed with spontaneous slowdown where I hadn't ever had a problem before.

    I'm going to try their recommended fix and update here.
  24. cjcampbell macrumors newbie


    Jan 25, 2008
    The fix apparently does not work for everyone. It did not work for me. The graphics issues apparently go deeper than that.
  25. Nano2k macrumors regular

    Nov 6, 2009
    From my experience the performance difference of WOW between Windows and OSX is abyssmal. Do yourself a favor, play WOW in bootcamp and get the full performance and eye candy. I doubt that OpenGL WOW will ever be much more than an half-assed job.

Share This Page