Wow... Text messages and 2.2

Discussion in 'iPhone' started by milani, Nov 21, 2008.

  1. milani macrumors 68000

    milani

    Joined:
    Aug 8, 2008
    #1
    Ok so over the past few days my iPhone has been really unstable. It's been freezing up/crashing, the battery meter froze and my phone died without me knowing my battery was low. A lot of weird things have been happening like 3G calls have been all distorted and fuzzy - I videotaped it it was so weird, and I'm going to put it on YouTube soon.

    My iPhone on many occasions has vibrated as if I have a text message when I have none. My friends iPhone actually started ringing one day from the home screen - yet no one was calling him. Often I have missed calls - yet my phone never rings and I just get a notification that I have a voice mail (and when I call the person back they say it was ringing on their end for 6 rings or whatever).

    So basically my iPhone has been acting mega weird. As of the past couple of days I hadn't got any text messages from any of my friends. I just assumed everyone was busy (finals coming up and what not). Anyway, so I just updated to 2.2, and as soon as my phone restarted, I slid to unlock, and I got 25 text message pop ups in sequence one right after the other from the past couple of days...
     
  2. diesel macrumors 6502a

    Joined:
    Aug 3, 2007
    #2
    Seems like you just needed to restart your phone. This happens to me once in a blue moon where it seems a lot of memory is taken up by something and calls don't get through but a restart fixes it.
     
  3. milani thread starter macrumors 68000

    milani

    Joined:
    Aug 8, 2008
    #3
    Restarted and reset my phone at least 10 times over the course of the week. I suspect it was a 3rd party application. I removed all the 3rd party apps minus Facebook, eBay, Wikiamo, Now Playing, Remote, and Score Mobile. I don't intend to download any new ones for a long time...

    I was also getting abysmal battery life, like my battery would last for 2 hours sometimes and then would be dead. I have doubt something was amiss, but removing most of the 3rd party apps I had and then updating the firmware seems to have fixed everything... I hope.
     

Share This Page