WPA log on problem with Airport

Discussion in 'macOS' started by Wongiranger, Jun 4, 2009.

  1. Wongiranger macrumors newbie

    Joined:
    Jul 11, 2008
    Location:
    London
    #1
    I have recently upgraded my wireless network to N+ using a Belkin Modem Router. Security is WPA2-PSK, and MAC access is disabled. All MacBooks (Leopard & Tiger), PCs (XP) and iphones connect without any problem, however my daughter's PowerBook G4 running OS X 10.4.11, and with the most recent Airport software, can't connect to the network.

    The password prompt when selecting the network only allows for entering a WEP password.

    Any suggestions gratefully received by a Dad who would do anything for his daughter save shell out for a new MacBook!!
     
  2. brop52 macrumors 68000

    brop52

    Joined:
    Feb 26, 2007
    Location:
    Michigan
    #2
    Try Other. Also, try TKIP rather than AES if that's what you are using.

    If it doesn't work, that means you have the earlier Airport card that only supports up to WPA. (Though I thought that issue was fixed along with AES).

    FYI that's a lot of G devices wasting the purchase of an N router.
     
  3. Jethryn Freyman macrumors 68020

    Jethryn Freyman

    Joined:
    Aug 9, 2007
    Location:
    Australia
    #3
    Does the Airport card in the Powerbook support 802.11G?
     
  4. Wongiranger thread starter macrumors newbie

    Joined:
    Jul 11, 2008
    Location:
    London
    #4
    Thanx for response...the options you suggest aren't available in any of the dialogue boxes - I'm only given a choice of 3 types of WEP and LEAP. Any further thoughts much appreciated!
     
  5. Wongiranger thread starter macrumors newbie

    Joined:
    Jul 11, 2008
    Location:
    London
    #5
    Yes it does - my previous set up was G. More details in following post...
     
  6. Wongiranger thread starter macrumors newbie

    Joined:
    Jul 11, 2008
    Location:
    London
    #6
    More details that may help you experts with suggestions...

    When I go into System Preferences -> Network -> Airport -> Preferred Networks, I select my SSID and am given the option to choose WPA2 Personal in the Wireless Security drop down box. My password is accepted and I click OK and Apply Now.

    I then select my network SSID in Airport, am only offered a choice of 3 WEP options and LEAP, and the password isn't accepted.

    I've tried the Setup Assistant, and again get a message that the password is invalid.

    I've tried the Diagnostics, and again only the WEP options are available.

    This is very frustrating......any further ideas most welcome!
     
  7. brop52 macrumors 68000

    brop52

    Joined:
    Feb 26, 2007
    Location:
    Michigan
    #7
    Remove your Preferred Network.

    Start from scratch and don't go directly to the SSID through the Airport Menu. Click Join Other Network in the Airport Menu and then type in the SSID and WPA2 Personal from the dropdown box. See if that helps.
     
  8. bdorpetzl macrumors regular

    bdorpetzl

    Joined:
    Jul 13, 2007
    Location:
    Port Washington, Wisconsin - Boats and Beer . . .
    #8
    TKIP should be set on the router. It is usually found under the WAP encryption algorithms. I have seen this problem before and that usually takes care of the problem. You may have to use WPA-PSK instead of WPA2-PSK as well.
     
  9. Wongiranger thread starter macrumors newbie

    Joined:
    Jul 11, 2008
    Location:
    London
    #9
    Thanks you for your suggestion, which I followed, but keep getting an error message "The wireless network "...." does not support the requested encryption method".

    The router's encryption method is WPA2-PSK which isn't an option offered in security drop-down box in the Airport set up.

    Does this mean I'll have to reconfigure the router to another (less secure??) encryption method, and then reset-up all the other computers in the network? Or maybe there is an OS X patch that can be downloaded? I've tried to find such a solution, but without success.
     
  10. Wongiranger thread starter macrumors newbie

    Joined:
    Jul 11, 2008
    Location:
    London
    #10
    Thanks for your reply. The manual security set up options on the router are as follows:
    Security Mode:
    • WPA-PSK (no server)
    • 128bit WEP
    • 64bit WEP
    Authentication:
    • WPA-PSK
    • WPA2-PSK
    • WPA-PSK + WPA2-PSK
    Encryption Technique options as per selection of the above

    If I manually change any of the settings, will this mean all computers, smartphones, gaming devices etc. will need to be reset? Will I need to create a new pre-shared key / password? Given that apart from the PowerBook G4 that won't connect, I'm reluctant to compromise the efficient operation of the other devices on the network.

    I look forward to your reply.
     
  11. bdorpetzl macrumors regular

    bdorpetzl

    Joined:
    Jul 13, 2007
    Location:
    Port Washington, Wisconsin - Boats and Beer . . .
    #11
    If you switch from WPA2-PSK to WPA-PSK, your router should allow you to us the same pre-shared key which shouldn't cause a problem with your other devices. Selecting WPA-PSK should allow you to pick TKIP only. Under Encryption Type you should be able to select AES or TKIP instead of AES or AES + TKIP. I had this problem with an iBook G4 running 10.3.9 and making the change to WPA-PSK using TKIP got the iBook running on the network.
     
  12. Wongiranger thread starter macrumors newbie

    Joined:
    Jul 11, 2008
    Location:
    London
    #12
    It got my daughter's iBook running as well! I did have to reset all other network devices, but all is running smoothly now. Many thanks for your help
     
  13. bdorpetzl macrumors regular

    bdorpetzl

    Joined:
    Jul 13, 2007
    Location:
    Port Washington, Wisconsin - Boats and Beer . . .
    #13
    Glad to hear you were able to get everything working.
     
  14. lysamb macrumors newbie

    Joined:
    Sep 13, 2009
    #14
    I've read through all your problems and suggestions and still can't get this to work. I've got the brand new Airport Extreme set up with my IMac and the PCs in the house all connect up 2 3 floors away but the G4 which is literally 10 feet from the base station keeps rejecting my password.

    I've recently replaced the airport card, thinking that was the problem and still no luck. I now have more $$ out on trying to connect than the machine is worth.

    So - Mac G4 w/airport card to Extreme Base station nearby - I get a rejection on the password. Any other hints or ideas?
     

Share This Page