WPA2 Enterprise WiFi & Certificates

TBONE72

macrumors regular
Original poster
Sep 25, 2007
186
11
I cannot accept the certificate when trying to join my company's WPA2 Enterprise WiFi network. Anyone else?
 

mstrshikadance

macrumors newbie
Oct 11, 2008
26
0
certificate bypass for wifi

In reply to all comments regarding the WI-FI issue.

I had the same issue myself connecting to the WI-FI.

My "fix" for this was using the iPhone configuration utility

Which can be downloaded here

Mac: http://support.apple.com/kb/dl1465

Windows: http://support.apple.com/kb/dl1466

After this open it up, plug your device into your computer and it should come up, it may just show a question mark, but don’t worry that’s fine it will still work.

Next go to configuration profiles and at the top left click new, this will then prompt you to fill in the general settings, here is where you must put the identifier of the device you want to install this certificate to.

Next click on the WI-FI tab and then configure, fill out your Wi-Fi information, by putting the SSID, security type. e.g. WPA2 and then the password if you have one.

After that go to your device, which will be the very last one on the list on the left, click on that then configuration profiles, it should show your profile, click install then on your device install it. Go to Wi-Fi on your phone and it should connect.

This is a method I used as I had trouble connecting to WI-FI I’m not saying it’s a full fix or there’s a bug.

Hope this helps you and any issue feel free to ask.
 

TexasChemE

macrumors 6502a
Oct 28, 2011
766
8
In reply to all comments regarding the WI-FI issue.

I had the same issue myself connecting to the WI-FI.

My "fix" for this was using the iPhone configuration utility

Which can be downloaded here

Mac: http://support.apple.com/kb/dl1465

Windows: http://support.apple.com/kb/dl1466

After this open it up, plug your device into your computer and it should come up, it may just show a question mark, but don’t worry that’s fine it will still work.

Next go to configuration profiles and at the top left click new, this will then prompt you to fill in the general settings, here is where you must put the identifier of the device you want to install this certificate to.

Next click on the WI-FI tab and then configure, fill out your Wi-Fi information, by putting the SSID, security type. e.g. WPA2 and then the password if you have one.

After that go to your device, which will be the very last one on the list on the left, click on that then configuration profiles, it should show your profile, click install then on your device install it. Go to Wi-Fi on your phone and it should connect.

This is a method I used as I had trouble connecting to WI-FI I’m not saying it’s a full fix or there’s a bug.

Hope this helps you and any issue feel free to ask.
Thanks for your help. I keep getting the error "Profile installation failed. The profile could not be added to this device"
 

TBONE72

macrumors regular
Original poster
Sep 25, 2007
186
11
In reply to all comments regarding the WI-FI issue.

I had the same issue myself connecting to the WI-FI.

My "fix" for this was using the iPhone configuration utility

Which can be downloaded here

Mac: http://support.apple.com/kb/dl1465

Windows: http://support.apple.com/kb/dl1466

After this open it up, plug your device into your computer and it should come up, it may just show a question mark, but don’t worry that’s fine it will still work.

Next go to configuration profiles and at the top left click new, this will then prompt you to fill in the general settings, here is where you must put the identifier of the device you want to install this certificate to.

Next click on the WI-FI tab and then configure, fill out your Wi-Fi information, by putting the SSID, security type. e.g. WPA2 and then the password if you have one.

After that go to your device, which will be the very last one on the list on the left, click on that then configuration profiles, it should show your profile, click install then on your device install it. Go to Wi-Fi on your phone and it should connect.

This is a method I used as I had trouble connecting to WI-FI I’m not saying it’s a full fix or there’s a bug.

Hope this helps you and any issue feel free to ask.
Interesting. Do you have to have a copy of the cert?
 

BFG86

macrumors 6502
Oct 14, 2011
397
88
probably a related issue but i couldn't get browser based logins to work for me. The screen would pop up but then that would redirect to the itunes store and it was an endless cycle
 

R4z3r

macrumors member
Jan 19, 2009
76
5
NJ
probably a related issue but i couldn't get browser based logins to work for me. The screen would pop up but then that would redirect to the itunes store and it was an endless cycle
Anytime browser based logins pop up for me they opened the podcasts application and kicked me out of the browser login. The only way to avoid that was to log in through the Settings application.
 

redsteel20

macrumors newbie
Jun 13, 2013
2
0
Has anyone gotten this to work with success?
Yes, I. Used the "iPhone configuration utility" tool from Apple.

First got the error:

Profile installation failed. The profile could not be added to this device"

Fixed it by sending a random certificate to my own mail and opening it up on the iPhone and installing it. Then I could install the profiles from the tool and removed the random certificate.

(iPhone 4s)