WPA2 with LEAP

Discussion in 'Mac Basics and Help' started by jadira, Jul 24, 2008.

  1. jadira macrumors newbie

    Joined:
    Jul 24, 2008
    #1
    i recently got a macbook pro - my first mac...but i can't seem to be able to authenticate on our wireless. i have all the information (i think) set up correctly before i try to connect to it, but it won't let me authenticate. i can see on the server that my account is trying to connect but failing...any ideas?
     
  2. NAG macrumors 68030

    NAG

    Joined:
    Aug 6, 2003
    Location:
    /usr/local/apps/nag
    #2
    We'll need more specifics as to exactly what you're doing and your OS version. I'm assuming your network uses LEAP (since I hope you wouldn't be trying that if it wasn't hehe).
     
  3. jadira thread starter macrumors newbie

    Joined:
    Jul 24, 2008
    #3
    details

    i'm running 10.4

    to try and connect i'm clicking on "other" under the network, typing in the correct network name, selecting the WPA2 Enterprise, and typing in my user name and pw.

    when i try to authenticate from there my computer doesn't authenticate and i get an error message.:confused:
     
  4. merl1n macrumors 65816

    merl1n

    Joined:
    Mar 30, 2008
    Location:
    New Jersey, USA
    #4
    You had better read this article to explain the usage of LEAP.

    http://en.wikipedia.org/wiki/Lightweight_Extensible_Authentication_Protocol

    1. It uses Dynamic (means the password changes frequently) WEP encryption, not WPA.

    2. If you want to save yourself some grief, disable LEAP, or if you can't, get another wireless router.
     
  5. jadira thread starter macrumors newbie

    Joined:
    Jul 24, 2008
    #5
    i can't disable LEAP...it's my bf's router and he won't dissable it because he doesn't want to use WPA PSK

    i'm just trying to figure out why it won't authenticate...is using LEAP the reason it won't authenticate?

    according to my bf: any PC is able to select WPA2 with LEAP and/or PEAP - is LEAP not mac friendly?
     
  6. merl1n macrumors 65816

    merl1n

    Joined:
    Mar 30, 2008
    Location:
    New Jersey, USA
    #6
    Well first thing is that you cannot authenticate using a WPA password if the router uses WEP.

    On the router, the WEP password used should have generated a Hexadecimal string. Ask your boyfriend for that string. Then when you try to connect to his network, use that Hex string as the password.

    But if the WEP password on the router dynamically changes, then you will (I think, but I'm not sure since I've never used LEAP) will need a new string every time you try to connect to his network.
     
  7. jadira thread starter macrumors newbie

    Joined:
    Jul 24, 2008
    #7
    its not using WEP - it's WPA Enterprise, not WPA PSK.
     
  8. fwhh macrumors regular

    Joined:
    Aug 11, 2004
    Location:
    Berlin, Germany
    #8
    Assuming you tried to set it up as "LEAP" or "WPA Enterprise" without success.
    Try to make an 802.1X profile with your Username, Password and the Networkname. In 10.4 you have to open "Internet Connection" and click on 802.1X in the toolbar. It there is no 802.1X option you can activate it via the menu (I think it's in File->New 802.1X Connection). Be sure to select LEAP as your authentication.
     
  9. jadira thread starter macrumors newbie

    Joined:
    Jul 24, 2008
    #9
    THANK YOU! this worked perfectly.
    :D
     

Share This Page