Wrong Artwork in iPod Touch

Discussion in 'iPod touch' started by anjinha, Jan 4, 2008.

  1. anjinha macrumors 604

    anjinha

    Joined:
    Oct 21, 2006
    Location:
    San Francisco, CA
    #1
    Some of my songs appear with the wrong artwork on my iPod Touch although they have the right artwork on iTunes. What can I do?
     
  2. chall5 macrumors regular

    Joined:
    Sep 19, 2007
    Location:
    UK
    #2
    reading some of the other threads on artwork would be a start
     
  3. anjinha thread starter macrumors 604

    anjinha

    Joined:
    Oct 21, 2006
    Location:
    San Francisco, CA
    #3
    I tryed that but I couldn't find what I want.
     
  4. cheekybobcat macrumors 6502a

    cheekybobcat

    Joined:
    Dec 26, 2007
    Location:
    U-S of A
    #4
    My only guess would be that something is wrong with your iPod. Id bring it to the apple store and ask them about it bcause it sounds like a hardware problem
     
  5. anjinha thread starter macrumors 604

    anjinha

    Joined:
    Oct 21, 2006
    Location:
    San Francisco, CA
    #5
    From what I've read in the foruns it seems more like a bug or software problem. Here's what happens:

    I'm searching for an album and I see that it has the wrong artwork. I select that album and it still displays the same wrong artwork or yet another wrong artwork but it always shows the correct one in Coverflow.

    Now from what I've read, if I erase all my music and then sync it again it displays all the right artwork but it starts getting "confused" as I sync new stuff into it.
     
  6. Kkatyboo macrumors member

    Joined:
    Nov 28, 2007
    #6
    i have that for one of my songs too... a bonjovi album artwork cover shows up for a tenacious d song... It's a annoying but I'll ignore it for now.
     
  7. dgriff21 macrumors newbie

    Joined:
    Jan 7, 2008
    #7
    I had the same problem.

    However I managed to fix it by selecting the affected songs in iTunes; selecting Get Info (Apple+I) and reassigning the artwork to the songs. Even though the correct artwork was showing in the display box, I deleted it and then reselected it. This cured it when I next Sync'd.
     
  8. JSchwage macrumors 6502a

    JSchwage

    Joined:
    May 5, 2006
    Location:
    Rochester, NY
    #8
    This actually used to happen to my original iPod nano. But one day it just seemed to fix itself. Weird.
     
  9. chall5 macrumors regular

    Joined:
    Sep 19, 2007
    Location:
    UK
    #9
    I have all my artwork working fine in iTunes and on my Touch, tags are the key, the only 'bug' I know of regarding artwork is when the Touch gets confused if two albums have the same name eg. Greatest Hits
     
  10. legacyb4 macrumors 6502

    Joined:
    Aug 13, 2002
    Location:
    Vancouver, BC
    #10
    My nano would have that problem from time to time... interestingly enough, it happened to me today as well using artwork from the Mahalo Daily podcast over a Chemical Brothers album.

    Removing the songs from the synced playlist, syncing, and adding back in seemed to fix the problem.

     
  11. wilsongs macrumors newbie

    Joined:
    Dec 6, 2007
    #11
    I'm having the same issue, seems to do it mostly with newly added things and things a play a lot. I'm guessing that it's just an annoying bug. Hopefully Apple wil fix it soon.
     
  12. mavis macrumors 68040

    mavis

    Joined:
    Jul 30, 2007
    Location:
    Tokyo, Japan
    #12
    I resolved this problem simply by re-syncing my music.

    I have about a half-dozen smart playlists feeding one 'master' playlist for my Touch, so I set the max playlist size for that master list to 3MB (which removed all of my music) and sync'd. I then removed the 3MB limitation and re-sync'd, and voila! All my album art was OK.
     

Share This Page