Wrong audio file icons

Discussion in 'Mac OS X Lion (10.7)' started by MrAppleseed, Apr 23, 2012.

  1. MrAppleseed macrumors member

    Joined:
    Apr 26, 2010
    #1
    Hi all!

    The audio file icons, on Mac OS X 10.7.3 on my MacBook Pro7,1 with the newest updates, seem to be somewhat confused. Instead of having this nice note icon…

    note.jpg

    …I see some random generic icons (when using iTunes as standard player) or a QuickTime symbol (when using QuickTime-Player as standard player) like those ones…

    generic.png

    It is even possible that one .m4a file has icon #1 while an other one has icon #2 (as shown above).

    This also makes it impossible to preview an audio file in icon view – the play button doesn’t show up when hovering over the file with the cursor. This all is true for the desktop and every folder. The audio type doesn’t matter as well, it neither works for .m4a, nor .mp3 files.

    The option to show previews of files is selected (and it actually works for all file types other than audio).

    Does anybody have an idea what’s wrong on my computer?
     
  2. Mal macrumors 603

    Mal

    Joined:
    Jan 6, 2002
    Location:
    Orlando
    #2
    What app are those files set to open with? If they're not set to open in Quicktime Player or iTunes, I've seen them do that.

    jW
     
  3. MrAppleseed thread starter macrumors member

    Joined:
    Apr 26, 2010
    #3
    I open them with QuickTime-Player by default. But the problem also occurs with having iTunes open them by default.
     
  4. fisherking macrumors 603

    fisherking

    Joined:
    Jul 16, 2010
    Location:
    ny somewhere
    #4
    try this:
    find an .m4a (for example), control-click it. go to get info.
    in the information window, tell it to open with iTunes (or QT if that's your preference).

    then click on "change all".
    confirm.

    do this for one of EACH file type you have a problem with.

    maybe repair permissions, reboot...

    see if that does it.
     
  5. MrAppleseed thread starter macrumors member

    Joined:
    Apr 26, 2010
    #5
    Sorry, fisherking, I should’ve expressed it more obvious, but I’ve already tried that. Unfortunately, it doesn’t help. The icons, however, change.

    For example I have two .m4a files on my desktop. With QuickTime-Player being the standard for .m4a files, it looks like this…

    QuickTime.png
    (Yes, those are exactly the same filetype, and I never changed the icons myself.)

    …and with iTunes as standard for .m4a they appear that way…

    iTunes.png

    Somewhere, I’ve read that the preview is only being shown when the icon size is greater or equal to 46 pixels; but my icons are even bigger than that.

    I have this feeling that there’s something wrong with QuickLook.
     
  6. Mal macrumors 603

    Mal

    Joined:
    Jan 6, 2002
    Location:
    Orlando
    #6
    Try going into ~/Library/Caches and deleting the files that start with com.apple.QuickLook (there are a few on my system). Then do the same in ~/Library/Preferences. Again, there were 3-4 files in there, just toss them all. Then restart (or log out/back in) and see if they behave better.

    jW
     
  7. MrAppleseed thread starter macrumors member

    Joined:
    Apr 26, 2010
    #7
    Thanks, but that doesn’t help either, unfortunately. But the tilde in your advice made me have a look at the situation at a different user (no new one, though). And this user appears to have exactly the same problem. So I guess it’s something system wide, isn’t it?
     
  8. MrAppleseed thread starter macrumors member

    Joined:
    Apr 26, 2010
    #8
    Fun facts:
    In CoverFlow, the icon is missing, but at least the play button shows up (for both the generic white icon and the grey exec icon):

    CoverFlow.png

    In column view, the small file icons are still wrong, but the preview on the right side is correct:

    Column.png
     
  9. uk1simon macrumors member

    Joined:
    Feb 25, 2011
    Location:
    UK
    #9
    Has anyone found a solution to this, same problem!!!
     
  10. MrAppleseed thread starter macrumors member

    Joined:
    Apr 26, 2010
    #10
    Unfortunately not. I'm still having the issue (now Mountain Lion 10.8.2, though). :(
     
  11. uk1simon macrumors member

    Joined:
    Feb 25, 2011
    Location:
    UK
  12. MrAppleseed thread starter macrumors member

    Joined:
    Apr 26, 2010
    #12
    Good news: I found a solution. Kind of bad news: it's an extremely awkward behaviour –*but at least it works.

    Start iTunes, remove all your voice memos from your library (back them up if you need them), quit iTunes. Restart Finder. Done. I hope that helps! :)

    That's my source. The person who wrote the solution said you could import the voice memos again without the problem re-occuring. I didn't try, though, because I don't need them there.
     
  13. uk1simon macrumors member

    Joined:
    Feb 25, 2011
    Location:
    UK
    #13
    WOW!!!

    Been looking for a solution to this for ages, it works!!!!

    Well done :)
     

Share This Page