Wrong free disk space

Discussion in 'Mac OS X Lion (10.7)' started by goncalossilva, Aug 22, 2011.

  1. goncalossilva macrumors newbie

    Joined:
    Aug 22, 2011
    #1
    Hello!

    I was copying a bunch of files from an external HD (~100GB) when my MacBook Air hibernated. When I powered it back on, the copy failed because the HD had been ejected unsafely (damn, I should have checked the battery status).

    I tried to copy everything again, but got an error about not having enough free space... so I moved everything I had copied so far to the trash and tried to erase it. It got stuck there, so I force quitted Finder and tried again. Nothing. Then I went with "rm -rf ~/.Trash/*". Nothing again. I decided to reboot the computer and try it again — it worked!

    But now I have a problem. While Finder reports that I have 190GB of disk space left (this is correct!), Disk Utility says that I only have around 90GB... and when I try to copy my ~100GB of files Finder says that I don't have enough space left.

    How can I fix this? These 100GB of missing space seems to be from the failed copy, but I don't know what to do.

    Thanks!

    PS. I'd "erase free space" on Disk Utility, but since this is an SSD with TRIM that option isn't available.
     
  2. goncalossilva thread starter macrumors newbie

    Joined:
    Aug 22, 2011
    #2
    So, I found the culprit: MobileBackups. TimeMachine was using 100GB+ on local backups (a new Lion "feature").

    If anyone might come across a similar issue, you can disable local backups running "sudo tmutil disablelocal" from the Terminal.
     

Share This Page