Wrong time on Macbook. Help please

Discussion in 'MacBook' started by DEF Hater, Sep 11, 2008.

  1. DEF Hater macrumors newbie

    Joined:
    Sep 9, 2008
    #1
    The clock on Macbook is wrong, in both OS X and Vista. I have it set to the right timezone and I try to sync it but it won't change to the right time. Is there a way to fix this in the os or the bios?
     
  2. TEG macrumors 604

    TEG

    Joined:
    Jan 21, 2002
    Location:
    Langley, Washington
    #2
    First, there is not BIOS.

    Second, In "Date & Time" in OS X, check to see you are setting the time automatically and that it is set to use time.apple.com. If that doesn't work, set the time manually.

    If the time that is appearing is in 1969, you have a bad PRAM battery and should get it replaced at an Apple Store or Repair Center.

    TEG
     
  3. Uoila macrumors member

    Joined:
    Oct 20, 2007
    #3
    Windows and OSX calculate time differently based on the system clock and only one of them can be right at a time. This can lead to your time being perpetually wrong since you boot windows and fix the time but break it on the mac. >> Boot mac, fix time, break it in windows.

    This might help.

    http://www.macosxhints.com/article.php?story=2006072022590888
     
  4. dclochri macrumors newbie

    Joined:
    Dec 17, 2009
    #4
    This helped with 2009 Macbook Pro, Snow Leopard

    http://www.maclife.com/forums/post/1664044

    Delete the file listed in the link. You might need to reset the configuration, but that should work.

    Here's the details:

    1. If the Date & Time preferences window is open, close it.
    2. From the Go menu choose Go to Folder.
    3. Type or paste the following location, then click Go.

    /private/etc/

    4. Delete the folder named "localtime".
    5. Enter your admin password if prompted.
    6. Select the correct time zone in the Time Zone tab of Date & Time preferences.


    ...worked for me.
     

Share This Page