WTF? Blank screen on my iMac?

Discussion in 'iMac' started by je1ani, Dec 26, 2007.

  1. je1ani macrumors 6502

    Joined:
    Sep 19, 2007
    #1
    So I get home today turn on my iMac and what do I see? A BLANK SCREEN!!! It's backlight still works but nothing comes up.. not even the Mac noise when you 1st boot up... When I turn it on that Welcome song plays... The worst part is even when I search google "Blank screen iMac" Black screen comes up in the search! WTF?! Any help?
     
  2. Nick12945 macrumors regular

    Joined:
    Aug 1, 2007
    Location:
    Michigan
    #2
    That just happened to me. Try resetting the p-ram. Command-Option-P-R at startup.
     
  3. je1ani thread starter macrumors 6502

    Joined:
    Sep 19, 2007
    #3
    Nope didn't work... This is real ******
     
  4. ParishM macrumors regular

    ParishM

    Joined:
    Aug 12, 2007
    Location:
    Ft. Lauderdale, Fla.
    #4
    if a hard reboot doesn't solve it then it's time to go back to apple.





    P....
     
  5. je1ani thread starter macrumors 6502

    Joined:
    Sep 19, 2007
    #5
    Well apple called me today said it wasn't a video issue but an LCD issue. So they're giving me a brand new iMac.. yay? I don't even remember what was on that computer because I stay mostly on my MBP god damnit lol
     
  6. JakeBrewer macrumors newbie

    Joined:
    Mar 24, 2008
    #6
    Same thing happened to me

    Tried resetting PRam. Tried just about everything under the sun. Thing has been alive for 6 days...

    Oh well. The idea of a new Mac is way less cool when you just got a new Mac.
     
  7. txhockey9404 macrumors 6502a

    Joined:
    Feb 25, 2008
    #7
    I have a launch week aluminum iMac (20inch 2.0ghz) and I just took it to the apple store this week for "intermittant shutdowns" and I got it back yesterday. When I started it up for the first time after the $700 repair job, i got the black screen issue. However, after a few forced restarts, it booted up normally. It still has the shutoff problem though, and now it cannot boot because it shut off during an os install. I'm taking it back later today...maybe they'll just give me a new one.

    Sorry for any typos...I'm on my iPod touch
     

Share This Page