WTF - Firmware update 2.9 bricked my mid-2011 MBA

Discussion in 'MacBook Air' started by Zeos, Jul 21, 2014.

  1. Zeos, Jul 21, 2014
    Last edited: Jul 21, 2014

    Zeos macrumors 6502

    Joined:
    Jan 24, 2008
    #1
    Installed the firmware, and now my mid-2011 13" MBA is bricked.

    Update: Resetting the SMC seems too have recovered my MBA following the firmware update.
     
  2. flowrider macrumors 601

    flowrider

    Joined:
    Nov 23, 2012
  3. Jimbola, Jul 22, 2014
    Last edited: Jul 23, 2014

    Jimbola macrumors newbie

    Joined:
    Jul 22, 2014
    #3
    I have a mid 2011 MBA too and since the update - I get nothing. Downloaded the update, was installing and went to restart and didn't. Since then I've tried to restart it a couple of times, sounds like it it tries to start but after a few seconds - silence. Have left my charger at work so hoping it will solve it in the morning.

    Updated: Resetting the SMC worked for me too and the firmware update is showing as installed. Worrying experience though.
     
  4. jojo26 macrumors newbie

    Joined:
    Mar 29, 2011
    #4
    I reset the PRAM and it fixed it. Or it may be coincidence as some time had elapsed? But still on older EFI and now it shows in available upgrades. Not installing until there is a fix.
     

Share This Page