WTF? "Movie Atom"

Discussion in 'Digital Video' started by Cave Man, Nov 15, 2007.

  1. Cave Man macrumors 604

    Cave Man

    #1
    I just tried opening a Quicktime video clip and I got the following from Quicktime:

    An invalid public movie atom was found in the movie.

    What is this? I've never seen this before.

    TIA
     
  2. roderick macrumors member

    Joined:
    Feb 16, 2008
  3. ewandaley macrumors newbie

    Joined:
    Feb 29, 2008
    #4
  4. Tallest Skil macrumors P6

    Tallest Skil

    Joined:
    Aug 13, 2006
    Location:
    1 Geostationary Tower Plaza
    #5
    I have both QuickTime and VLC on my computer... and that last article didn't help at all. How does installing another program help the first program play a file?

    I'm getting the movie atom error on an mp4, if that helps. It's 1080p. It went into iTunes fine, but it hung when I added artwork, so I Force Quit iTunes and now both QuickTime and iTunes refuse to recognize it.
     
  5. glennpow macrumors newbie

    Joined:
    Jan 9, 2009
    #6
    Sometimes the simplest answer...

    If you have both Quicktime and VLC installed, try this:
    1. Quit Quicktime :apple:
    2. Start VLC :cool:
    3. Select File -> Open, and find that pesky mp4 file.
    4. Hit Play and enjoy the streaming goodness.
     
  6. gkarris macrumors 604

    gkarris

    Joined:
    Dec 31, 2004
    Location:
    "No escape from Reality..."
    #7
    Re-encode in Handbrake and click on "Insert iPod Atom"?
     
  7. mannox macrumors newbie

    Joined:
    Apr 22, 2009
    #8
    Invalid Public Movie Atom SOLUTION!

    IF you have the files saved on an external drive (or even if they were at ANY point saved on an external drive), go to your manuf's website and download the latest firmware upgrade for that external drive. Worked for me and solved ALL my .dmg issues, ALL my public movie atom issues, and all my "Error 4960" issues.

    If the files became "corrupt" at some point (while they were on an external drive) - copying them to another location would only be making copies of broken files. You have to go back to the drive (hopefully they are still there). Keeping the files ON the drive, update the firmware. Everything came back for me, instantly. Whew!

    mannox@gmail.com
     
  8. Cave Man thread starter macrumors 604

    Cave Man

    #9
    Nothing like dusting off a year and a half old thread...
     
  9. ashrayer macrumors newbie

    Joined:
    Sep 4, 2011
    #10
    Try this

    I've got this same error when I try to open a .mov file by QuickTime 7.

    I convert this .mov file from a mkv file via FFMPEG.

    Here is my way to solve this problem:

    Step-1, Open Mkvtoolnix.

    Step-2, Add the original .mkv file in the list of "Input files".

    Step-3, In my case, I found 2 objects in this .mkv file aside of VIDEO and AUDIO, they are subtitle and chapter XML. Uncheck these 2 objects.

    Step-4, Click "Start muxing" button to create a new .mkv file, which only contains VIDEO and AUDIO.

    Step-5, Convert this new .mkv file to mp4/mov/m4v again.

    I am not sure this solution will fix everyone's situation, but it solve my problem. Good luck!
     
  10. arjen92 macrumors 65816

    arjen92

    Joined:
    Sep 9, 2008
    Location:
    Below sea level
    #11
    The article says something about not having the proper codec. Instead of looking for all codecs you can just install perian. (perian.org). It contains all codecs in an easy ... umm, let's call it a plugin. That way quicktime will play almost every file.
     
  11. Cave Man thread starter macrumors 604

    Cave Man

    #12
    Nothing like dusting off a 4 year old thread... ;)
     
  12. ppc_michael Guest

    ppc_michael

    Joined:
    Apr 26, 2005
    Location:
    Los Angeles, CA
    #13
    Did you solve your problem? It would be helpful if you posted your solution so that a)others would know this was solved and to stop posting and b)others googling the same problem will be helped with this thread.
     
  13. littlebear macrumors newbie

    Joined:
    Jan 13, 2012
    #14
  14. master.cob macrumors newbie

    Joined:
    Mar 17, 2006
    Location:
    Portland, OR
    #15
    But Pacifist is a $20 program. Does it work even if it's not registered? Seems crappy to have to pay $20 just to downgrade Quicktime Pro so that you can watch/edit .mov files...
     
  15. macpunc macrumors newbie

    Joined:
    Jun 27, 2008
    #16
    If your file extension is .mp4 try changing it to .m4v.

    This has worked for me on many files with this problem.

    Also make sure you have Perian installed.

    cheers
     

Share This Page