Wtf......version r u????

Discussion in 'iPod touch' started by WarBourne, Mar 25, 2009.

  1. WarBourne macrumors newbie

    Joined:
    Jan 19, 2009
    #1
    i'm confused, im going to get the refurbrished 1g ipod touch 8gb off the apple store online....... but now im hearing something on the forums about upgrading the 1g ipod to 2.2 when you get it or it wont let u play games???? :confused: please help me out in explaning what this all means..... thanks......

    -follow up to my other post "refurbrished"
     
  2. Mackilroy macrumors 68040

    Mackilroy

    Joined:
    Jun 29, 2006
    #2
    Your post doesn't make much sense… you're asking if you have to upgrade the iPod's OS or else apps/games won't work? No. Apps will work unless they require 2.2.

    EDIT: I just read the post where you heard that - he's wrong. You should upgrade, but you don't absolutely have to unless the app/game you want requires it to run. Much like how iTunes 8.1 requires 10.5.6 or later.
     
  3. Consultant macrumors G5

    Consultant

    Joined:
    Jun 27, 2007
    #3
    Instead of the extremely useless title of
    "Wtf......version r u????"

    You should change thread title to:
    what iPod touch os do I need to play xyz game?

    Or actually call up apple and ASK them.
     
  4. alphaod macrumors Core

    alphaod

    Joined:
    Feb 9, 2008
    Location:
    NYC
    #4
    It has been found that the processor and the GPU of the first generation iPod touch is noticeably slower and inferior to the second generation iPod touch. There isn't really a list of games that do or do not work, just that the first generation iPod touch is less powerful; I have a first generation iPod touch, and games play fine. Certain hardware is not available on the iPod touch 1st gen like Bluetooth and such; there may be applications in the future that require such appliances, which would make them unusable on the iPod touch 1st gen.

    As with the software itself, as far as I'm concerned I have iPhone OS 2.2 and everything works fine and dandy.

    For future compatibility sake it would be a better idea to buy the second generation iPod touch simply because some hardware enhancements cannot be added with software updates to the iPod touch 1st generation.

    I hope that answers your question.
     
  5. cmichaelb macrumors 68020

    cmichaelb

    Joined:
    Aug 6, 2008
    Location:
    Kansas
    #5
    I totally agree. I have both generations of Touches and you do notice some speed difference in how the iPod responds but so far apps that don't require 2nd gen hardware work fine.

    I also agree that you should go with the 2nd gen for the faster processor inside it and a little more future proof as new apps come out taking advantage of the changes in 3.0 that are hardware specific. Plus, the 2nd gen just feels better in the hand and I think the wifi reception is improved in the 2nd gen.
     

Share This Page