Wth apple, again?! Problems with Wi-Fi and cellular data

Discussion in 'iOS 8' started by geeshiet, Mar 7, 2015.

  1. geeshiet, Mar 7, 2015
    Last edited by a moderator: Mar 7, 2015

    geeshiet macrumors member

    May 26, 2014
    I'm getting very frustrated. This has been happening since Apple first launched ios 8. It might be my router or my damn phone, I dont know but I'm going to blame Apple for this because they are **** for releasing updates that leads to more bugs. Reason why I'm frustrated is that it takes a really long time to load something like websites, and apps... Anything that requires Internet connection but in this case I'm using my wifi. Secondly, my stupid iPhone indicates that it is connected to my router but isn't displaying the wifi signal that is next to the carrier... Worst of all it uses my data instead of my wifi. I'm starting to hate iPhones now... I can't deal with this buggy software anymore. ImageUploadedByTapatalk1425718137.617168.jpg
  2. Mlrollin91 macrumors G5


    Nov 20, 2008
    Ventura County
    Have you tried resetting network settings? A restore and setting up as new?

    I have not once encountered this issue, not on my iPad 2 or iPhone 6. my GF hasn't on her iPhone 5S either, all running iOS 8.
  3. geeshiet, Mar 7, 2015
    Last edited: Mar 7, 2015

    geeshiet thread starter macrumors member

    May 26, 2014
    Wth apple, again?! Problems with Wi-Fi and cellular data

    Yes I did reset my network settings but the issue still persists. As for restoring, no I haven't because it's just too stressful. Having to download all the apps again, logging into my emails which sucks because I might not even remember one of my emails password, restoring my photos, etc... It's total bs. If I said anything wrong, I'm sorry because I'm fairly new to iPhones. I had my iPhone for about 8 months, and yes I'm still learning -_-
  4. BigInDallas macrumors regular


    Oct 13, 2014
    I understand not wanting to set up as new but it really is the best way to attempt a fix. My 6+ wifi is rock solid. Only real big I have is the damn landscape rotation thing. Any others I either don't see or my use doesn't encounter them
  5. zone23 macrumors 68000

    May 10, 2012
    Have you considered not owning a smartphone if it stresses you out so bad? Seriously take a deep breath go outside for a while.

    If you decide that you can handle it then I would reset the phone and not restore the backup and see if that corrects the problem. Then if that doesn't work I would either call Apple and get a replacement or take it to an Apple store and have them look at it. I would not get so bent out of shape.
  6. swordfish5736 macrumors 68000


    Jun 29, 2007
    that means it is having trouble connecting to your ATT DSL gateway/router and cannot obtain an IP address. Try looking at the configuration of your router.

    You say your wifi is slow, what is the speed of your home internet?
  7. I7guy macrumors G5

    Nov 30, 2013
    Looking at Central Park@550 feet
    Did you try turning the phone off and on and/or rebooting your router?
  8. XTheLancerX macrumors 68000


    Aug 20, 2014
    NY, USA
    I haven't had any issues either on my iPad mini 2 or iPhone 6. Try Settings>General>Reset>Reset Network Settings, and reboot the router as well. If you have a PC or other device that is not experiencing any WiFi issues at all, test the Internet speed/ping at http://www.speedtest.net. Or use the speed test app by ookla if it is a mobile device.
  9. Joe70 macrumors newbie

    Mar 7, 2015
  10. C DM macrumors Westmere

    Oct 17, 2011
    Yeah, it's either something with the router and/or its WiFi access point or there's something with the WiFi capabilities on the phone (unless there are no issues connecting to and using other WiFi connections using the same phone).
  11. Max(IT) Suspended


    Dec 8, 2009
    It most probably is your router or your internet connection, so nothing to blame on Apple.
    But to be sure you can take your device to an Apple store and have it checked. It would takes minutes to find it's ok.
  12. I7guy macrumors G5

    Nov 30, 2013
    Looking at Central Park@550 feet
    Not the same thing. The OP appears to have a wifi connected phone without the wifi symbol in the upper left, signifying the phone is using cellular data.

    The other post is people stating their wifi connection is not fast enough in a general sense that is the gist of the ops' post.
  13. richwoodrocket macrumors 68020


    Apr 7, 2014
    Hamburg, NY
    Dont blame apple for the fault of your internet connection. Judging by what i can see in your partially censored censored wifi network name, it appears you are using the stand issue ISP router. Get a new access point and see if you are still having problems
  14. Deetlebug89 macrumors member

    Feb 2, 2014
    I had a few encounters with wifi problems myself,

    After trying to reset network settings and forgetting networks to reconnect fresh nothing seemed to work, however at a friend house with a apple router everything worked great

    Then back at my house and others who had equally crappy routers the problem still existed, so I got an apple router and now everything is flawless.... I'm not gonna say exactly that it's gotta be a apple router but I would seriously advise getting a a newer more powerful router and I wouldn't be surprised if your problems stop

    It also made AirPlay to my Apple TV have no lag so I can play games on tv from my iPhone without any frame skips and lag :)

    Completely worth the 100$ imo
  15. C DM macrumors Westmere

    Oct 17, 2011
    And the fact that the phone seems to connect to the WiFi network but is then confused as to whether or not it's actually connected to it is an indicator of that being the only possibility?
  16. Armen macrumors 604


    Apr 30, 2013
    Restart your router. Yes, I'm aware that other devices may be working fine and it's easier to blame your phone but do it anyway. Another user like you had issues with Wifi on his iPhone where everything else was working and restarting his router fixed it for him.

Share This Page