WunderRadio now mutes in Sleep mode - WTF?!

Discussion in 'iOS Apps' started by FearlessFreep, Nov 21, 2008.

  1. FearlessFreep macrumors 6502a

    Joined:
    Jul 15, 2008
    Location:
    Northern Virginia, USA
    #1
    Downloaded the WunderRadio 'update' last night and now when you sleep your phone, either by pressing the top button, or when the phone automatically sleeps [shuts off screen] the audio out is muted! Stupid, stupid feature/bug that essentially renders the app USELESS now. Anyone else get this?
     
  2. fastbite macrumors 6502a

    fastbite

    Joined:
    Jul 23, 2007
    Location:
    London
    #2
    yes, I get the same problem. I was having a bath this morning listening and I had to get out three bloody times to reset it! Until I realized what the problem was. I hope they sort it out.
     
  3. geoelectric macrumors 6502

    geoelectric

    Joined:
    May 19, 2008
    #3
    Edit: didn't notice you said WunderRadio update, not just 2.2 in general.

    If you downloaded 2.2 at the same time, it might not be WunderRadio.

    Ambiance and WhiteNoise are showing similar behavior post-firmware-update; they mute at sleep, which pretty much breaks them. Also, the phone appears to hard-mute in "Silence" mode now for these apps.

    Even if they fix the sleep/mute issue (which I assume is a bug) the silence switch forced-mute is unfortunate. There's a clear need to be able to turn off unexpected noises (calls, texts, etc.) and keep expected ones (the white noise generator you're sleeping to).
     
  4. FearlessFreep thread starter macrumors 6502a

    Joined:
    Jul 15, 2008
    Location:
    Northern Virginia, USA
    #4
    Yep, I've got Ambiance and it does the same thing. Definitely a 2.2 bug.
     
  5. CommanderData macrumors regular

    Joined:
    Dec 1, 2007
    #5
    Apple changed the way the AudioQueue works in 2.2, so that it suspends playback when your iPhone sleeps (shuts the screen off).

    Fortunately there is a way to change your code easily so that your AudioQueue will continue in sleep mode. For any developers reading this forum- mikeln at iPhonedevSDK forums figured it out...
    The default audio session for 2.2 has changed from:

    kAudioSessionCategory_MediaPlayback

    to

    kAudioSessionCategory_SoloAmbientSound

    It looks like programmers have to set the audio session as MediaPlayback explicitly, where previously it was assumed.
     
  6. geoelectric macrumors 6502

    geoelectric

    Joined:
    May 19, 2008
    #6
    And I figure MediaPlayback probably solves both issues, sleep and the silence switch.

    It's actually a good change on their part--most apps -should- follow the silence switch and sleep--but I bet it throws a bunch of ambient noise/music/podcast/etc. apps off until they update.
     

Share This Page