X over battery icon but still able to use the computer without the power supply

Discussion in 'MacBook' started by illogikal, May 26, 2009.

  1. illogikal macrumors newbie

    Joined:
    May 26, 2009
    #1
    Starting this morning an X has appeared over my battery icon.
    When I click the icon is says no battery available.
    When I check the system profiler it says no battery installed.
    When I click the button on the battery all 6 lights turn on.
    I have read similar posts to this that say when they unplug the power supply the mac turns off in a few minutes, mine however will stay on the same amount of time as if the battery was charged.
    I'm surprised that this happened because I bought a new battery 3 months ago because the original one short circuited when my hard drive went last summer. I had to have the power supply constantly plugged in if I was using the computer.
    I tried shutting down the computer, removing the battery and restarting and that worked. However when I shut down, unplugged the power supply and tried to restart, it did not turn on.
    I'm hoping there is a solution as I use my laptop on the road often and not being able to turn it on without the power supply is a real inconvenience.
    Has anyone had a problem like this? Is there a solution?
     
  2. jtibbitt macrumors regular

    jtibbitt

    Joined:
    Jan 3, 2009
    #2
    Not good. Your battery probably will not charge. When its current charge empties, you may not be able to charge it again and will need to always use the power cord. This has happened to others (search the forums). It happened to me and the problem ended up being a faulty logic board. It is an expensive repair. I hope you have Applecare.
     
  3. bozz2006 macrumors 68030

    bozz2006

    Joined:
    Aug 24, 2007
    Location:
    Minnesota
    #3
    that's weird! Is there a way to zap the PRAM for the macbook, or something like that? If so, I'd try that. Sorry, i don't know off the top of my head how you do that with the macbook.
     
  4. illogikal thread starter macrumors newbie

    Joined:
    May 26, 2009
    #4
    It does charge, I let the battery run out, then plugged the power supply back in and now I can still remove it.
     
  5. MedHead macrumors regular

    Joined:
    Mar 2, 2009
    Location:
    Cork, Ireland
    #5
    Try resetting the PRAM as mentioned above and failing that repair permissions via disk utility!
     

Share This Page