x11 bin

Discussion in 'Mac Basics and Help' started by cbookworm, Jul 20, 2010.

  1. cbookworm macrumors newbie

    Joined:
    Jul 20, 2010
    #1
    Have used this utility with inkscape for over a year with no problems. Today it keeps quitting unexpectedly even when I closed inkscape. I get this message:

    Process: X11.bin [4923]
    Path: /Applications/Utilities/X11.app/Contents/MacOS/X11.bin
    Identifier: X11.bin
    Version: ??? (???)
    Code Type: X86 (Native)
    Parent Process: X [4919]

    Interval Since Last Report: 41 sec
    Crashes Since Last Report: 3
    Per-App Interval Since Last Report: 0 sec
    Per-App Crashes Since Last Report: 3

    Date/Time: 2010-07-20 18:53:43.398 -0400
    OS Version: Mac OS X 10.5.8 (9L31a)
    Report Version: 6
    Anonymous UUID: 8D75109A-3B3E-4D5F-9727-35B8EB396C09

    Exception Type: EXC_BREAKPOINT (SIGTRAP)
    Exception Codes: 0x0000000000000002, 0x0000000000000000
    Crashed Thread: 0

    Dyld Error Message:
    Library not loaded: /usr/X11/lib/libpixman-1.0.dylib
    Referenced from: /Applications/Utilities/X11.app/Contents/MacOS/X11.bin
    Reason: Incompatible library version: X11.bin requires version 15.0.0 or later, but libpixman-1.0.dylib provides version 13.0.0


    Not sure what or why library version is incompatible or how to fix as I added nothing to my computer today. Any help would be appreciated.
     
  2. MacKeeperFanMod macrumors regular

    MacKeeperFanMod

    Joined:
    Jun 28, 2010
    #2
    X11 fails to start after Security Update 2010-002
    Download and install the 10.5.8 COMBO update, repair permissions, and restart. If that doesn't do the trick, repost to the Unix forum under OS X Technologies for Unix, Terminal, and X11 issues.

    Good luck!:)
     
  3. mac2x macrumors 65816

    Joined:
    Sep 19, 2009
    #4
    This happened to me...just reinstall/update X11 and all should be well.
     

Share This Page