X11 issues with Leopard; Gimp crashes due to dyld error

Discussion in 'macOS' started by yeroen, Oct 28, 2007.

  1. yeroen macrumors 6502a

    yeroen

    Joined:
    Mar 8, 2007
    Location:
    Cambridge, MA
    #1
    Anyone else having trouble with their X11 installation after upgrading to Leopard?

    Every time I launch Gimp, it crashes due to the following dynamic loading error:

    Dyld Error Message:
    Library not loaded: /usr/X11/lib/libfontconfig.1.dylib
    Referenced from: /usr/X11R6/lib/libXft.2.dylib
    Reason: Incompatible library version: libXft.2.dylib requires version 3.0.0 or later, but libfontconfig.1.dylib provides version 2.0.0


    But here's the output of otool -L /usr/X11/lib/libfontconfig.1.dylib:

    /usr/X11/lib/libfontconfig.dylib:
    /usr/X11/lib/libfontconfig.1.dylib (compatibility version 3.0.0, current version 3.0.0)


    Anyone else have this problem? What gives?
     
  2. yeroen thread starter macrumors 6502a

    yeroen

    Joined:
    Mar 8, 2007
    Location:
    Cambridge, MA
  3. dr_lha macrumors 68000

    Joined:
    Oct 8, 2003
    #3
    Pretty much, yes, although a lot of the issues are due to the way they changed how X11 works on Leopard.

    However, the main issue is that X11 and Spaces combo is basically unusable, a bit of an issue because most people who use X11 a lot are used to multiple desktops, so Spaces is a must have feature for them.
     
  4. yeroen thread starter macrumors 6502a

    yeroen

    Joined:
    Mar 8, 2007
    Location:
    Cambridge, MA
    #4
    sorted it out, for now

    Installing the latest Intel binary of Gimp for Mac OS X, v2.4 rc3 from http://www.gimp.org/downloads/
    fixed the problem.

    I'm wondering if the error reporting is incorrect and that the version of libfontconfig delivered in the older Gimp.app bundle (Gimp.app/Contents/Resources/lib/libfontconfig.1.dylib) bundle was being loaded instead of the one in /usr/X11. The version of libfontconfig delivered with the older Gimp.app bundle was 2.0.0.
     
  5. mealybar macrumors newbie

    Joined:
    Oct 30, 2007
    #5
    Gimp on a G4 Leopard

    Hi,

    Does this mean (intel version) that I won't have an installation of GIMP that will run on my G4 iMac running Leopard?

    Are there any alternatives?

    Richard
     
  6. ~Shard~ macrumors P6

    ~Shard~

    Joined:
    Jun 4, 2003
    Location:
    1123.6536.5321
    #6
    As a GIMP user, this is a good thing to know. Thnaks for the head's up and the subsequent links to the Apple discussions. Another reason for me to hold off upgrading to Leopard just for now... :eek: ;)
     
  7. shanecoder macrumors newbie

    Joined:
    Aug 21, 2009
    #7
    Gimp 2.6.7 and Quartz 2.4.0 work great on OS/X 10.5.8

    I was having several problems with Gimp crashing. I upgraded to the three versions listed above. Everything is working good now.
     

Share This Page