X11 Xquartz MAC OS 10.8.5

Discussion in 'Mac Programming' started by cbb, Sep 18, 2013.

  1. cbb macrumors newbie

    Sep 18, 2013
    In my new MAC OS 10.8.5 MacBook Pro I followed the instructions given by Apple and installed the Xquartz application. I do see and I can work in my X11 windows when I call XQuartz. However old programs like LyX (latex), GS (GhostScript) and Nedit (Text editor) do not work and claim that X11 is not installed. Any ideas?
  2. MisterMe macrumors G4


    Jul 17, 2002
    GhostScript is part of the OS. You don't need a second installation. Is there some reason why you don't want to use the OS X-native version of LyX? BTW, have you installed MacTeX?
  3. Madd the Sane macrumors 6502a

    Madd the Sane

    Nov 8, 2010
    In order for Xquartz to be set up properly, you need to log out then back in after installation.
  4. cbb thread starter macrumors newbie

    Sep 18, 2013
    Yes all fine and installed. I just gave you some examples of programs that do not work in the Xquatz...they all say that X11 is not working. The one I really need to run is Nedit.
  5. alex0002, Sep 26, 2013
    Last edited: Sep 26, 2013

    alex0002 macrumors 6502

    Jun 19, 2013
    New Zealand
    Did you compile nedit yourself? The MacOSX executable from sourceforge appears to be written for PowerPC, as it gives me the error:

    bash: /usr/local/bin/nedit: Bad CPU type in executable
    I'm guessing you either compiled it yourself or downloaded from another site. Perhaps you might need to get the source and recompile?

    Do your DISPLAY and PATH environment variables look o.k. in the terminal?
    Something like this...

    $ echo $DISPLAY
    $ echo $PATH
    If you have access to a linux or other machine running an ssh server, can you start an ssh session with X11 forwarding and start the applications on those machines and view them on the Mac?

    This might determine if this is a display or execution environment issue.

    In the case of Lyx did you get your Lyx dmg from lyx.org and follow the information here:

    E.g. follow the instruction about Gatekeeper on Mountain Lion and the part about needing a TeX installation.

    Or did you compile a pure X windows Lyx from source?
    I'm guessing the later. Did you use Homebrew or Macports, or some other method?

    Back to Nedit... can you post the specific error messages?
  6. alex0002, Sep 27, 2013
    Last edited: Sep 27, 2013

    alex0002 macrumors 6502

    Jun 19, 2013
    New Zealand
    The following worked for me on Mountain Lion.

    1. Open the URL: http://ftp.nl.freebsd.org/editors/NEdit/v5_5/executables/

    2. Download the file containing the intel version of nedit: nedit-5.5-MacOSX-intel.tar.gz

    3. Start XQuartz and open a terminal (xterm).

    4. In the xterm window open the nedit archive:

    tar xvzf ~/Downloads/nedit-5.5-MacOSX-intel.tar.gz
    x nedit-5.5-Darwin-i386/
    x nedit-5.5-Darwin-i386/COPYRIGHT
    x nedit-5.5-Darwin-i386/faq.txt
    x nedit-5.5-Darwin-i386/nc
    x nedit-5.5-Darwin-i386/nc.man
    x nedit-5.5-Darwin-i386/nedit
    x nedit-5.5-Darwin-i386/nedit.doc
    x nedit-5.5-Darwin-i386/nedit.html
    x nedit-5.5-Darwin-i386/nedit.man
    x nedit-5.5-Darwin-i386/README
    x nedit-5.5-Darwin-i386/ReleaseNotes
    5. Place the nedit binary in the PATH, so it can be started from command line.

    sudo cp -p nedit-5.5-Darwin-i386/nedit /usr/local/bin/
    6. Start nedit from within the xterm session.

    nedit &
    This starts the nedit application and it is possible to open a file and edit it.
    Does this work for you? If not, which step fails?
  7. cbb, Oct 1, 2013
    Last edited: Oct 1, 2013

    cbb thread starter macrumors newbie

    Sep 18, 2013

    Dear All

    Following/understanding some of your propositions and according to personal experience, I realized that there was something wrong with my Xtools. Than I downloaded and installed the new Xcode version from Apple (Version 5.0 (5A1413)) and I updated the "command line tools" using the download components within Xcode peferences.

    Than, I download and installed again XQuatz.

    After that everything was fine.
    All programs using X11 work in my computer.

    My conclusion: when I migrated the contents of my old Mac (10.6.8) to the new one (10.8.5) some features did worked well but some not. So, Xtools are not 100% compatible among different MacOs versions.

    Thank you all.

Share This Page