XBMC with aTV2 4.2 - no 5.1+ audio from attached storage

Discussion in 'Apple TV and Home Theater' started by 3282868, Apr 2, 2011.

  1. 3282868 macrumors 603

    Joined:
    Jan 8, 2009
    #1
    This seems to be an issue with a lot of people, and I've spent weeks trying to remedy it. XBMC forums, googling, speaking with techs, you name it.

    Setup:
    · ATV2 "opened" using Seas0nPass running iOS 4.2 (4.1.1)
    · XBMC (Some reason it states 10.0-0, other settings 10.0-7 as I installed the nightly build recently)
    · Pioneer Elite VSX-33 7.1 - Digital Core DSP Engine, THX certified, 192K/24-Bot DACs, DDP, Dolby Pro Logic Plus and llz, DTS-HD, WMA9 Pro, PQLS Jitter Reduction via HDMI, DSD to PCM Converter, etc.

    I've ripped full DVD backups on my Mac Pro using Fairmount or MTR 4.0, then Handbrake for m4v conversion. When possible I choose AC3 6-channel discrete or AC3 5.1-channel with the highest Bitrate (roughly 640 kbps) for layer one, then AAC for layer two 2-channel devices. Once done, I can stream the m4v perfectly to my aTV2 system via iTunes from my Mac Pro. Full sound, amazing quality.

    I have my Pioneer AVR for internet radio and my aTV2 attached via ethernet to a second "Time Capsule" that is connected to my main "Time Capsule". My aTV2 accesses my m4v's perfectly on the "Time Capsules" HDD and acts as sort of a NAS device ("Time Capsule" HDD configured for sharing, configured SMB in XBMC to access the HDD). Sound in the main aTV2 menu works, however in XBMC I have no sound in clicking through menus, and all the same exact m4v's copied to the "Time Capsule" HDD only output 2-channel stereo (selecting ACL audio/THX/etc simply transmits the stereo signal through 5 channels).

    I have spent weeks researching the prominent issue, tried optical audio instead of HDMI, configured both the AVR and aTV2 to ensure everything is in sync. Still decodes to 2-channel stereo.

    This seems to be an issue with XBMC as some have pointed out possible bit streaming issues. Using ethernet from aTV2 to "Time Capsule" HDD" should not pose an issue. If anyone has any expert knowledge I seemed to have missed I would greatly appreciate any any any help. Heck, I'll PAY you lol.
     
  2. 3282868 thread starter macrumors 603

    Joined:
    Jan 8, 2009
    #3
    You got me all excited but, yeah :eek:

    I've read all the threads on XBMC about this issue, as well as MacRumors, RipDifferent, "Mac the Ripper" (got "Mac the Ripper 4.0" as well as "RipIt"). I don't know why the aTV 2 handles the same m4v's streamed via iTunes perfectly, but playing the same files I drag-and-drop to that "Time Capsule" HDD played via ethernet through XBMC configured to access the files via SMB only play in 2-channel audio. I even tried the optical cable w/ HDMI "fix", making sure my Pioneer Elite VSX-33 receiver, aTV 2 and XBMC recognize the optical audio connection. Nothing.

    I love a challenge, one of the reasons I refuse to give in, but at this point, I'm waving my white flag lol. I'll have to live with using one of my Mac Pro SATA bays and streaming through iTunes. I really wanted this for my parents, as they have an iMac with the exact same AVR and an aTV 2. My father is in a wheelchair from a double leg amputation due to juvenile diabetes complications, and I wanted to avoid having him make certain his iMac is running w/ iTunes and an attached external HDD. Oh well.

    Thanks so much for the help man! That was a hard link to find, I didn't read it until last week. :)
     
  3. gunthermic macrumors 6502

    Joined:
    Sep 15, 2010
    #4
    I have been trying to help you in another thread.. I know your frustration. have you tried havign the movie file not on the time capsule and seeign how XMBC. You describ a TC hooked to another TC and such, possible to be causing issues having it go through all this? I am sure you have, but sometimes we forget the stupid little things when trying to track down an issue.

    I would assume after all your readign that XMBC does play 5.1? So what about a differnet format to the XMBC? That woudl ensure that it's playing 5.1 to begin with and not just the movie file.
     
  4. 3282868 thread starter macrumors 603

    Joined:
    Jan 8, 2009
    #5
    Oh yeah, thanks again, I didn't realize that was you :).

    I'm using my second "Time Capsule" to simply extend my wireless network, and to supply internet to my Pioneer VSX-33 as it only has ethernet not WiFi, and also to connect my ATV 2 in order to access the 1TB HDD. For some it works, for others it doesn't. XBMC does support 7.1/5.1/AC3/AAC/AC3-Passthru/etc. I've tried using optical with HDMI, I've tried modding the info.plist although the latest build of XBMC allows this through the settings menu now.

    I'm threading back and forth with one of the XBMC engineers now, and I'm trying another build that may work.
     
  5. DaveNinja macrumors 6502

    DaveNinja

    Joined:
    Oct 18, 2005
    #6
    have you tried it with movie files someone else made? like with a downloaded clip with dts?
     

Share This Page