Xbox 360 controller disables trackpad and keyboard when removed

Discussion in 'Mac Accessories' started by jwms1985, Sep 11, 2011.

  1. jwms1985 macrumors newbie

    Joined:
    Sep 11, 2011
    #1
    Hello

    First time posting on this forum so thought I should begin with a 'Hi.'

    I have been having a bit of trouble with my wired xbox 360 controller. I tried to get the rumble feature to work on the controller. After a bit of mucking around I discovered that when I remove the controller my the key board and mouse are disabled and the only thing I can do is press and hold the power button and wait for it to shut down.

    When it is plug it into the computer via USB it works as it should. This is the web site I got the original driver from;

    http://tattiebogle.net/index.php/ProjectRoot/Xbox360Controller/OsxDriver

    I was wondering if anyone have any suggestions to fix this issue.

    Thank you
     
  2. dominicmck macrumors newbie

    Joined:
    Aug 3, 2008
    #2
    Hi, I am getting the same problem. Originally it was working fine on my early 2011 macbook pro 13". Then I reinstalled snow leopard and this problem started happening. I am using the latest version of the tattiebogle driver, and I am now on Lion.

    While it is not a fix I did find out that Logmein still works so at least I can use that to save work and do a clean restart.

    Also if the system goes to sleep when it wakes up the controller doesn't work at all. I have to restart to get it working ok. I use Gamepad Companion from the app store it that is any help.

    I'll post an update if I find any solution.
     
  3. BenJuan26 macrumors newbie

    Joined:
    Sep 17, 2011
    Location:
    Canada
    #3
    Hey guys, I bought my 15" MacBook Pro right when they made them with firmware that ONLY supports OS X Lion. I've been wanting to downgrade for other reasons, other programs that I want to run such as Pro Tools 8... but I'm out of luck there. This also means that I'm stuck running this driver on Lion as well.
    I've had the exact same problem upon unplugging. I sent Colin Munro an email describing the problem, and hopefully he can figure it out, but in the meantime I realized that closing my MacBook and letting it sleep, then unplugging the controller avoided this error. I know it's still a bit of a pain but it worked for me and so far it's the only workaround that I have heard of. I hope this helps.
     
  4. yawns macrumors member

    Joined:
    Oct 12, 2011
    #4
    Got here from Google. I'm having the same problem under Lion on an "early 2011" MBP. My keyboard and trackpad stop working, and my USB ports usually die, too. If I plug a mouse in after pulling the controller, it doesn't light up/turn on. If I have the mouse plugged in prior to disconnecting the controller, it will occasionally keep working. Usually I need to connect remotely and reboot.

    Checking the logs, right as I pull the controller I get an error that says something like, "GetUSBDeviceInformation() failed with KIOReturnNotResponding." Google kind of indicates that this means something like, "The USB subsystem can't talk to the device, so it's totally flipping out." Perhaps if there was a way to gracefully remove the controller, that would fix it, but I have no idea. I've also tried reloading USB drivers, they keyboard, and so on, though they all state that they're, "in use," and won't let me. If there's a way to force the USB stack to restart/reload, that might fix it. Though even then you'd still need remote access, which is dumb.
     
  5. ekundayo macrumors newbie

    Joined:
    Oct 12, 2011
    #5
    Wow, finally found this thread from google too. I thought I was the only one.
    Likewise an early 2011 MBP, originally snow leopard, now 10.7.2.
    I've had the problem across the board with any game I've tried, and indeed when just plugging in and then unplugging the controller.


    I've emailed too, but Colin seems completely unresponsive. Perhaps there's a way to force a restart of him?

    *Queue groans*
     
  6. farayman3 macrumors newbie

    Joined:
    Dec 16, 2011
    #6
    I have this problem too. Wish I found out about this before I bought my new controller... Anybody found a fix yet?
     
  7. capz macrumors newbie

    Joined:
    Jan 1, 2008
    #7
    the best solution that i've found so far is not unplugging the controller after use. It may take your mac a little longer to power down at the end of your day (if you power it down at all), but I've had no issues what so ever since I started simply leaving the controller attached all day.

    Also, the driver's change log states that it's not finished and could use some error checking. I'm guessing that if someone were to implement error checking (someone familiar with Objective-C and Cocoa + IOKit), all of our issues would magically disappear. It's open source so it could be done. Unfortunately I don't have the spare time, nor obj-c/cocoa, let alone IOKit experience to implement these fixes. else I would have :(

    Edit: i've also found the same problems to occur on 10.6, so I'm no sure how people didn't notice these issues until lion came out ; /
     
  8. IeU macrumors member

    Joined:
    May 1, 2011
    #8
    News.

    http://tattiebogle.net/index.php/ProjectRoot/Xbox360Controller/OsxDriver

     

Share This Page