Xbox 360 controller driving me crazy

Discussion in 'iMac' started by -Ghost, Jun 26, 2011.

  1. -Ghost macrumors newbie

    Joined:
    Dec 11, 2010
    #1
    So I'm wanting to try using a controller for TF2 now that it is free (please no comments about keyboard/mouse > controller). I've been a console guy all my life and trying to play a fast paced FPS with WASD is just not working out for me right now.
    Anyway, I've tried plugging a 360 controller into every usb port I have but it kills every one of them. Says that it's taking too much power and shuts down the port until I restart my comp. This is getting very irritating as something this simple shouldn't be such a pain in the ass.
     
  2. tsugaru macrumors 6502

    Joined:
    Feb 9, 2003
    Location:
    Edmonton
    #2
    Odd. I use an X360 controller for a few games in Windows 7 on my iMac (GTA4, Jamestown, Street Fighter 4, etc.) and it works properly, regardless of whether it is plugged into a hub or directly to the machine.
     
  3. Objector macrumors member

    Joined:
    May 16, 2011
    #3
    You can try to use a powered usb hub? That way the controller doesn't have to draw it's power from the iMac.
     
  4. -Ghost thread starter macrumors newbie

    Joined:
    Dec 11, 2010
    #4
    Ugh, this is so weird.
    I haven't read anywhere of people having this problem.
    Could it possibly be my controller? It's not in the greatest of condition.

    I don't have one, or the money to get one. And I shouldn't need it anyway.
     
  5. tsugaru macrumors 6502

    Joined:
    Feb 9, 2003
    Location:
    Edmonton
    #5
    Borrow another one from a friend and see if that works?

    I've tried all 4 from my 360. I can't replicate your issue.
     
  6. monchote macrumors newbie

    Joined:
    Jun 30, 2010
    #6
    You don't specify whether you are using Mac or Windows to play TeamFortress2.

    If you are using Mac, then I am afraid that the controller won't work. Try installing Windows 7 on Bootcamp and it should work just fine.
     
  7. dh2005 macrumors 6502a

    Joined:
    Jan 25, 2010
    #7
    That's not necessarily true. I use my 360 controller to play Half-Life 2 and Portal 2, on both the Windows and the OS X side of my iMac. The controller won't work natively, though - you'll need to download a driver.
     
  8. Fuith macrumors member

    Joined:
    May 5, 2011
    Location:
    Tralee, Co. Kerry, Ireland
    #8
    Just checking, but it is one of the hardwired controllers rather than a wireless one with the cable attached right?
     
  9. dgr macrumors member

    Joined:
    Jun 24, 2011
    #9
    Which driver are you using? The one from here...
    http://tattiebogle.net/index.php/ProjectRoot/Xbox360Controller

    I can't get it to work. :(
     

Share This Page