xcode 3.0 not installing!!

Discussion in 'PowerPC Macs' started by ADChu, Jul 27, 2015.

  1. ADChu macrumors newbie

    ADChu

    Joined:
    Jul 27, 2015
    #1
    I have no clue if this is an xcode package problem or a problem with the DMG but here goes.

    A few days ago I got this perfect condition powerbook rev D G4. The system is flawless and runs smoothly. I wanted a video editor that I knew and come to find out kdenlive is available in macports I decided I wanted to install MP.

    Problem for me is xcode. 3.0 to be exact. I download the DMG and try to mount it but when I do it says "No mountable file system". Other DMG's are fine and intel DMG's open just fine so it has nothing to do with that.

    I'm not sure how to fix this as I am a newb to the mac world but I have found it fascinating to learn about and look forward to getting a mac in the future.

    Thx for the help!
     
  2. eyoungren macrumors P6

    eyoungren

    Joined:
    Aug 31, 2011
    Location:
    Phoenix • 85037
    #2
    Try redownloading the DMG. That error is a result of incomplete data. Either when it was uploaded or the download itself.

    If downloaded again and you get the same error, see if you can find the DMG from another source.
     
  3. ADChu thread starter macrumors newbie

    ADChu

    Joined:
    Jul 27, 2015
    #3
    I have redownloaded it at least twice. I'm not sure where else to look so if you have any ideas I would appreciate it!
     
  4. eyoungren macrumors P6

    eyoungren

    Joined:
    Aug 31, 2011
    Location:
    Phoenix • 85037
    #4
    Sorry. I don't know where else you can get it except from Apple's dev site. If it's not working there…IDK. Maybe someone else might have it, but I don't know if they can link to it or not.
     
  5. MacCubed macrumors 68000

    MacCubed

    Joined:
    Apr 26, 2014
    Location:
    Florida
  6. Altemose macrumors G3

    Altemose

    Joined:
    Mar 26, 2013
    Location:
    Elkton, Maryland
    #6
    I would recommend downloading the Xcode 3.1.4 tools as they are a bit more up to date and I know the download is not damaged from Apple as I used it recently.
     
  7. flyrod macrumors 6502

    flyrod

    Joined:
    Jan 12, 2015
    #7
    Are you running 10.4? It might require 10.5; I'm on xcode 2.5 with various mods to get newer gcc and other tools. iirc this was as far as I could go on 10.4 but I don't remember exactly.
     
  8. Altemose macrumors G3

    Altemose

    Joined:
    Mar 26, 2013
    Location:
    Elkton, Maryland
    #8
    Xcode 2.x is compatible with Tiger but 3.0 and 3.1 are Leopard only.
     
  9. flyrod macrumors 6502

    flyrod

    Joined:
    Jan 12, 2015
    #9
    Do you happen to know what 3 does on 10.4? Could that be what the OP is experiencing?
     
  10. Altemose macrumors G3

    Altemose

    Joined:
    Mar 26, 2013
    Location:
    Elkton, Maryland
    #10
    Xcode 3 will not run on Tiger at all and will not even install. It will however be able to build 10.4 compatible apps and programs.
     

Share This Page