Xcode 4.3.1 Crashing

Discussion in 'Mac Apps and Mac App Store' started by bainsteven, Apr 16, 2012.

  1. bainsteven macrumors newbie

    Joined:
    Apr 16, 2012
    #1
    Hiya Guys,

    I am running Xcode 4.3.1 on a MacMini with Mac OS 10.7.3 (2.3 GHz Intel Core i5, 2GB 1333 MHz DDR3). It has previously been working fine.

    However, now when I add an Object to a View, hold CTRL, drag a connection to the Code Window, add a Name, and click "Connect" - Xcode will close!

    Please find attached a copy of the error report (which I am repeatedly sending to Apple). If anyone can make any sense of this it'll be much appreciated!

    I have tried reinstalling several times and still the same result.

    Has anyone got any suggestions?!

    Cheers,

    Steve.
     

    Attached Files:

  2. bainsteven thread starter macrumors newbie

    Joined:
    Apr 16, 2012
    #2
    Solved!

    I somehow had two matching "@interface" declarations in my code!

    This was causing Xcode to crash when trying to add a new Connection. Removing the unwanted "@interface" fixed the issue.

    Hopefully this will help someone else in the future.

    FOR REFERENCE: Ensure your code is correct and compiles before adding anything new!!! :)

    Steve.
     
  3. charliex5 macrumors regular

    Joined:
    Jun 27, 2008
    Location:
    Seattle, WA
    #3
    Ha! This always happens to me. As soon as I ask for help on something I end up figuring it out myself, even if I've been working on it for days. Good luck with your coding!

    :)
     

Share This Page