Xcode 6 GM is broken

Discussion in 'OS X Yosemite (10.10)' started by timmyrosen, Sep 11, 2014.

  1. timmyrosen macrumors newbie

    Joined:
    Sep 11, 2014
    #1
    Hi!

    I'm running OSX Yosemite Dev preview 7 (the latest atm) and I just downloaded Xcode 6 GM Seed and installed. Although when I try to launch it an alert pops up and says that "Xcode is broken and can not be opened".

    I have tried rebooting the computer, re-installing the software multiple times but it still happens.

    Anyone who knows that this is and how to fix it?
     
  2. afsnyder macrumors 65816

    Joined:
    Jan 7, 2014
    #2
    Maybe it doesn't work under yosemite? Do you need yosemite to run Xcode 6?
     
  3. timmyrosen thread starter macrumors newbie

    Joined:
    Sep 11, 2014
    #3
    Xcode 6 should most definitly work on Yosemite.

    I can't seem to install Xcode 5 either, since it says that I have a "too new" version of the OS...

    What to do?
     
  4. Watabou macrumors 68040

    Watabou

    Joined:
    Feb 10, 2008
    Location:
    United States
    #4
    Xcode 6 GM will not work on Yosemite. It's only for Mavericks.

    You need to download Xcode 6.1 beta.
     
  5. timmyrosen, Sep 12, 2014
    Last edited: Sep 12, 2014

    timmyrosen thread starter macrumors newbie

    Joined:
    Sep 11, 2014
    #5
    I tried downloading Xcode 6.1 Beta and the same thing happened. The icon bounces for like a minute, and then an alert pops up and says "Xcode-Beta is damaged and can not be opened. It should be moved to the trashcan"

    This is really frustrating, and really need to be able to use Xcode.

    Does anyone have any suggestions?
     
  6. timmyrosen thread starter macrumors newbie

    Joined:
    Sep 11, 2014
    #6
    I just downloaded a copy of the 5.1.1 version from the Apple Developer site and even that didn't work!

    The same alert box comes up!
    What is this madness?
     
  7. Manesh macrumors member

    Joined:
    Oct 30, 2013
    #7
    Same

    Me neither, i tried Xcode 6GM and Xcode 5.1 and neither works, Xcode just bounces up and down on the dock until i quit it.
     
  8. waterskier2007 macrumors 68000

    waterskier2007

    Joined:
    Jun 19, 2007
    Location:
    White Lake, MI
    #8
    XCode 6 GM absolutely works in Yosemite. I am running it right now
     
  9. Mr. Retrofire macrumors 601

    Mr. Retrofire

    Joined:
    Mar 2, 2010
    Location:
    www.emiliana.cl/en
    #9
    Gatekeeper?
     

Share This Page