XCode asking for password to Build & Debug

Discussion in 'Mac Programming' started by BadWolf13, Nov 8, 2012.

  1. BadWolf13 macrumors 6502

    Dec 17, 2009
    Ever since I reinstalled from a backup, I've been getting this window popping up when I try to build and debug a program in XCode. It says "Type your password to allow Developer Tools Access to make changes." Now if I type in my password, it builds and runs just fine. It won't ask me for my password again, until I log out, or turn the computer off. Then, it repeats the process. Not exactly debilitating, but annoying nonetheless. Anyone got any ideas how to fix this?

    Oh, and if you're curious, I am logged in as the admin.
  2. MacAndor macrumors newbie

    Feb 11, 2012
    Hi! Try fixing your permissions, ultimately reinstall Xcode.
  3. chown33 macrumors 604

    Aug 9, 2009
    on the Western Slopes, with E. A. Poe
    What have you tried? Be specific.

    If I google the error message Type your password to allow Developer Tools Access, the first result is this:

    One reply describes how to add a user to the _developer group. Another reply mentions the DevToolsSecurity tool used from Terminal. Additional replies that describe other solutions, depending on Xcode and OS version. Since you didn't state your versions, you'll have to choose an applicable reply.

    If you've already tried all of those things, then please say so. If you haven't, then see the link for details, and maybe try more googling.

    Also, post the output of this command:
    id -p
    and see if you're a member of the _developer group.
  4. BadWolf13 thread starter macrumors 6502

    Dec 17, 2009
    Tried fixing permissions, didn't help.
    Tried googling, didn't find anything useful.
    Am part of the _developer group.

    I'll try reinstalling XCode to see if that helps.
  5. Senor Cuete macrumors 6502

    Nov 9, 2011
    Try this:

    Open a project. Open the organizer window from the windows menu. Click on the devices icon in the window header. In the column on the left there should be a heading called Devices. Select your machine under devices. Your computer should appear in the right (main) panel. There should be a button labeled "Enable developer mode". Click on it. This might work.
  6. BadWolf13 thread starter macrumors 6502

    Dec 17, 2009
    Thank you Senor, but it appears that your suggestion won't be necessary. Reinstalling XCode worked perfectly, thank you MacAndor.

Share This Page