Xcode Build/Run problem

Discussion in 'Mac Programming' started by Basibo1, Nov 22, 2011.

  1. Basibo1 macrumors newbie

    Joined:
    Jun 22, 2011
    #1
    I've installed Xcode 4.2.1 on Mac OS X Lion.
    When I create a new (Mac OS X Cocoa) project and I click "Run", Xcode says build succeeded, but doesn't run the project. No errors, but no application either.
    When I do exactly the same thing on another Mac (but with OS X Snow Leopard and Xcode 4.0.1 installed), the created app starts bouncing in the dock and shows an empty window, like I would expect.
    When I look in the Console, there seems to be nothing strange going on.
    I tried reinstalling Xcode, deleting everything related to Xcode, but still no luck.
    Anyone got an idea what could be the problem?

    Thanks in advance,

    Basibo1
     
  2. AxiomaticRubric macrumors regular

    AxiomaticRubric

    Joined:
    Sep 24, 2010
    Location:
    On Mars, Praising the Omnissiah
    #2
    I'm not 100% certain but this might be a new feature in Xcode 4.2. Try putting some generic content in a XIB file (making sure it's properly referenced in a view controller, etc.) and see if running the app opens the simulator. If this doesn't bring up the simulator then you've got something else going on.
     
  3. Basibo1 thread starter macrumors newbie

    Joined:
    Jun 22, 2011
    #3
    Nope, that didn't work either. Still no window showing up.
    Thanks for the help
     
  4. Basibo1 thread starter macrumors newbie

    Joined:
    Jun 22, 2011
    #4
    In the scheme, the debugger was set to GDB, it should've been LLDB. Now the app runs fine.
     
  5. jiminaus macrumors 65816

    jiminaus

    Joined:
    Dec 16, 2010
    Location:
    Sydney
    #5
    You've got a really nasty, salient bug if your program works under LLDB but not GDB. Any well-behaved program should run equally well under either, and neither.
     
  6. Basibo1 thread starter macrumors newbie

    Joined:
    Jun 22, 2011
    #6
    Yeah that's strange, but I'm really happy it works now :)
     

Share This Page