Xcode built app wont run on 10.5.8

Discussion in 'Mac Programming' started by Tomas Sinkunas, Mar 3, 2011.

  1. Tomas Sinkunas macrumors newbie

    Joined:
    Mar 3, 2011
    #1
    Hi guys. I am new here and new in Xcode world.

    I made a simple app with Xcode 3.2 on Snow Leopard.
    The resulting built app works on snow leopard, however it will not even start on leopard (10.5.8) - I get message "You cannot use this version of application with this version of Mac OS X". Is it normal?

    Or is there a way to make app that will work both on Snow Leopard and Leopard? Please advise, as I have no way to find out myself:(

    Thanks for any input
     
  2. robbieduncan Moderator emeritus

    robbieduncan

    Joined:
    Jul 24, 2002
    Location:
    London
    #2
    Oh come on now, that's simply not true. This is covered in the documentation. You just have to read it.

    For example Tech Note 2064 is pretty helpful. As is the SDK Compatibility Guide.
     
  3. Tomas Sinkunas thread starter macrumors newbie

    Joined:
    Mar 3, 2011
    #3
    thank you for your help

    Thank you for your help.
    All I did was selected Targets - MyApp - Get Info and under Build tab i changed "Mac OS X Deployment" from "Mac OS X 10.6" to "Mac OS X 10.5" and it seems it works.

    As my app is super simple and there's no difficult stuff, algorythms and nothing, it's just like a calculator with some text fields and buttons and that's it. So I assume I can even go lower to version 10.4.

    Any ways, appreciate your input.

    Cheers.
     

Share This Page