Xcode: Error Creating and Opening Projects

Discussion in 'Mac Programming' started by arvz, Aug 10, 2008.

  1. arvz macrumors newbie

    Joined:
    Aug 10, 2008
    #1
    Hey guys, I have found some similar threads to my following question but none have been the same or have helped me fix this

    I downloaded and installed Xcode 3.1 yesterday and installed it on my macbook, running Leopard.

    I go to create new project: command line tool: standard tool (infact, any project at all will spawn this same error..) and receive this unfriendly error:

    Uncaught Exception:
    *** -[NSTreeController setUsesIdenticalComparisonOfModelObjects:]: unrecognized selector sent to instance 0x2fa4eb0

    Stack Backtrace:
    The stack backtrace has been logged to the console

    I get to choose either Quit or Continue. If I choose quit Xcode closes, continue makes the error dissapear, and creates the project folder with the .xcodeproj file in it. Then nothing happens. I can try to open the xcodeproj file manually, but that just gives me another random error which sometimes comes up. Other times when I try to open a project nothing happens.

    Any idea?
     
  2. cMacSW macrumors regular

    Joined:
    Mar 20, 2006
    #2
    Sounds like you may need to re-install xcode.
     
  3. arvz thread starter macrumors newbie

    Joined:
    Aug 10, 2008
    #3
    already did that, same error. I even re-downloaded the setup.
     
  4. lazydog macrumors 6502a

    Joined:
    Sep 3, 2005
    Location:
    Cramlington, UK
    #4
    I had something like that happen too but the problem just went away. I don't know what I did. Perhaps if you open a project and save the preferences out again it might help. Sorry I can't be any more helpful.

    b e n
     
  5. arvz thread starter macrumors newbie

    Joined:
    Aug 10, 2008
    #5
    actually i managed to fix it by updating mac osx to the latest version. I was running leopard but hadnt updated to the latest version. Now creating and loading projects are not an issue, but another problem arises. I will make a new thread for that.
     

Share This Page