xcode keychain access denial leads to exit 1 signal 0

Discussion in 'iOS Programming' started by theprizerevealed, Mar 22, 2018.

  1. theprizerevealed, Mar 22, 2018
    Last edited: Mar 22, 2018

    theprizerevealed macrumors member

    Joined:
    Feb 26, 2016
    #1
    all right I encountered a new problem here,
    I was ready to send my app to itunes connect for approval.

    So I followed the usual steps, Edit > Scheme > Archive then went to Product >Archive.

    Well, this time it prompted me for keychain access so I tried inputing my macOS admin password and it didn't recognize it so I tried my apple ID password and it didn't recognize it. So finally just to escape the dialog box I clicked the Deny button.

    So when I went to try again then this Task failed with exit 1 signal 0 message appeared in xcode.

    I googled it and there are sparse, varied and complex directions to try to fix the problem. I tried going to KeyChain Access and looking for an xcode certification or key that might need changing but I'm not sure what to look for.

    There was an issue of a discrepancy of the bundle identifier between Xcode and itunes connect and I'm wondering if that's what prompted the keychain access issue from Xcode. I corrected the discrepancy and now the bundle identifier corresponds in both xcode and itunes connect however the issues persists.

    Also, I tried cleaning the build to no avail.

    Any suggestions?
     
  2. PhoneyDeveloper, Mar 24, 2018
    Last edited: Mar 24, 2018

    PhoneyDeveloper macrumors 68040

    PhoneyDeveloper

    Joined:
    Sep 2, 2008
    #2
    Your developer credentials are stored in your Mac System Keychain. You can see them there by using Keychain Assistant.

    To build an Archive you set the device to 'Generic iOS Device' and choose Product > Archive. You don't normally have to do anything with the scheme. If it prompts you for Keychain Access you enter your Mac Admin Password. There are a couple more steps to submit to the app store but that's about it, assuming there are no errors.

    Since you told the system to Deny Xcode access your code-signing fails. I would try to lock the login keychain in Keychain Assistant and then try again. It will ask you again to access the Keychain. This time type in your Mac admin password and choose Always allow.

    Also, you can view or edit the access control for your distribution cert in Keychain Assistant. Double-click the private key inside the cert. Choose Access Control from the dialog. What I see is Xcode.app and code sign listed and 'Confirm before allowing access' set. I don't know how Deny is stored. If you don't have Confirm ... set then set that and try to codesign. I think you'll be prompted again.
     
  3. theprizerevealed thread starter macrumors member

    Joined:
    Feb 26, 2016
    #3
    Thanks, I tried again trying this and it worked. But I needed also to restart the computer to make it work. Then the dialog box reappeared. I didn't need to lock the keychain fortunately. But that's good to remember. Also, I must have entered my password wrongly. It was late at night. It works now..
     

Share This Page