Xcode Organizer: can not use iPhone (dyld_shared_cache_extract_dylibs failed)

Discussion in 'iOS Programming' started by slurmomatic, Jan 22, 2011.

  1. slurmomatic, Jan 22, 2011
    Last edited by a moderator: Jan 23, 2011

    slurmomatic macrumors newbie

    Sep 9, 2008
    When plugging my iPhone in and starting the Xcode organizer, a yellow circle next to the device show me that "This device is busy or otherwise unusable by Xcode." The Organizer is then processing two files (the second one takes quite a while to finish) and afterwards I get the error message as shown in the screenshot.

    I tried to google for that error message ("dyld_shared_cache_extract_dylibs failed") but could not find anything useful. I tried a couple things: repair permissions of my harddrive and run "sudo update_dyld_shared_cache -force". Still getting the error message.

    I am running iOS 4.2.1 and Xcode 3.2.5. I have not updated Xcode after updating from 4.2 to 4.2.1 (I think).

  2. slurmomatic thread starter macrumors newbie

    Sep 9, 2008
    With the help of somebody at the Apple Developer Forums I was able to fix the problem by removing the "/Developer/Platforms/iPhoneOS.platform/DeviceSupport/4.2.1 (8C148)" folder. Xcode then re-added the symbols automatically and the error disappeared. For more information see this thread: https://devforums.apple.com/message/367667#367667

Share This Page