iOS XCode Simulator running slow

lastcall

macrumors member
Original poster
Jan 10, 2013
51
5
I'm running XCode 5 with the latest Mavericks 10.9.1 update, and whenever I use the iOS 6.0/6.1 simulator,
my app runs extremely slow with choppy graphics.

I found this command after searching on the subject:
> sudo sysctl -w kern.timer.coalescing_enabled=0

But I have absolutely no idea what it does or what effects it has on my computer.
I don't understand why I even need to do it at all.
 

Duncan C

macrumors 6502a
Jan 21, 2008
853
0
Northern Virginia
I'm running XCode 5 with the latest Mavericks 10.9.1 update, and whenever I use the iOS 6.0/6.1 simulator,
my app runs extremely slow with choppy graphics.

I found this command after searching on the subject:
> sudo sysctl -w kern.timer.coalescing_enabled=0

But I have absolutely no idea what it does or what effects it has on my computer.
I don't understand why I even need to do it at all.
I remember reading about that, but don't recall the specifics. It is legit anyway. It's not like somebody's trying to get you to type "sudo rm -rf /" or something.

I'd suggest googling it.

Are you doing a lot of logging (using printf, NSLog, or debugger breakpoints with logging)? Those really slow down your code a lot.
 

lastcall

macrumors member
Original poster
Jan 10, 2013
51
5
This is old app of mine that has ran smoothly in the past, in both release and debug mode. The only thing that has changed is Mavericks.

If I change to a different simulator other than iOS 6.0/6.1, the problem seems to go away. But, this is very odd behavior. Something that I shouldn't have to fix myself, as it seems to be related to the operating system.
 

Tander

macrumors 6502a
Oct 21, 2011
676
1
Johannesburg, South Africa
Which version of Xcode 5 are you running? 5.1?

If so.. from the release notes:

iOS Simulator!
Developers may experience performance issues when running apps within the iOS Simulator on Mavericks with a simulated OS version of iOS 6.1 or earlier. The suggested workaround for this issue is to disable timer coalescing while using the iOS 6.1 or earlier simulator. (15501929):
sudo sysctl -w kern.timer.coalescing_enabled=0
The iOS simulator sometimes stops responding to hardware keyboard. Usually, quitting and relaunching the simulator will correct this. (14642684)
Hope this helps.
 
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.