Xcode terminating abnormally

Discussion in 'Mac Programming' started by sujithkrishnan, May 11, 2008.

  1. sujithkrishnan macrumors 6502

    Joined:
    May 9, 2008
    Location:
    Bangalore
    #1
    Hi all,

    I found that the Xcode is exiting abnormally whenever i type some particular lines
    eg : myCustomArray arrayObject = [[myCustomArray alloc] init];

    As soon as i type 'alloc' the Xcode shows a busy mouse icon and terminate, showing an error message like 'Xcode application terminated with som error code.

    Kindly help me regarding this, being a beginner to the world of MAC (2 weeks)
    I dont know much about the settings and preferences for Xcode..
     
  2. tacoman667 macrumors regular

    Joined:
    Mar 27, 2008
    #2
    Is this in the 3.1 Beta version or 3.0 proper? I have experienced this in the 3.1 version before. It seemed to happen when I tried to alloc memory for an object. The syntax is probably incorrect and Xcode gets caught into some kind of infinite loop of initializing something. I am guessing, and this is only a guess, that Xcode runs out of memory resources and then crashes.

    If this happens in Xcode 3.1 beta and not in 3.0 proper then expect to see quirks like this until they release a RTM version probably at WWDC in June. Either way, send in a bug report if you have the ability to in the Dev Center of Apple's website and let them know as well.
     
  3. sujithkrishnan thread starter macrumors 6502

    Joined:
    May 9, 2008
    Location:
    Bangalore
    #3
    Thank You...
     
  4. tacoman667 macrumors regular

    Joined:
    Mar 27, 2008
    #4
    Glad to help!
     

Share This Page