Xcode: Uncategorized: error: open /usr/share/man/man1/test.1: Permission Denied

Discussion in 'Mac Programming' started by djmoody, Jul 23, 2012.

  1. djmoody macrumors regular

    May 13, 2012
    Ok, so this error is happening in objective-C as well, but I've tried recreating it compiled in the simplest C program possible, because that is what I'm familiar with.

    Just started using Xcode, and this is my first Mac as a programmer (used a mac before I started programming). I started using Xcode, and have started getting the hang of it. However, I was trying to figure out if there was a way to get the build to compile to /usr/local/bin, which it wasn't doing even though I created the directory and set the Installation directory there.

    So basically I tried different building types (run, profile, analyze, etc), and one came up with a weird error.
    error:open /usr/share/man/man1/test.1: Permission denied

    So I created a c test program to show what happens, I created the base c Xcode project, and set "Build Phases"-->"Copy Files"-->"Copy Only When Installing" unchecked for test.1

    Anyone have any clue/more information they want me to give them?

    main.c and test.1 are just the default for this test.
  2. DOGONO macrumors newbie

    Jul 25, 2012

Share This Page