Mac Xcode where to specify -Xmx and -Xms runtime options?

m3the01

macrumors member
Original poster
Jun 18, 2007
70
0
This is for java,

Thanks for the help,

Just cant seem to locate it.

thanks again
 

Littleodie914

macrumors 68000
Jun 9, 2004
1,813
7
Rochester, NY
Could you be a bit more specific? What is the purpose of the -Xmx and -Xms arguments? Are you trying to compile?

In your source list on the left, there's a Group titled "Executables." (If I understand your question correctly.) Expand this group, and click on the executable you want to add the options for. Click the "Info" button in the toolbar, then on the "Arguments" tab of the window that pops up.

This is, as far as I know, the easiest way to add runtime arguments to the java compiler from within XCode. :)
 

m3the01

macrumors member
Original poster
Jun 18, 2007
70
0
Sorry i assume to much,

See normally when using the standard java runtime call your would say something like this

java -Xms64m -Xmx256m fileThatContainsMain

I assume there is somewhere in xcode that i code specify these flags.

thanks for the help!
 

m3the01

macrumors member
Original poster
Jun 18, 2007
70
0
Hey i followed your directions, i actually found that place earlier and attempted but still nothing works.

I tried calling it
name = -Xmx256m value = -Xmx256m
name = -Xms256m value = -Xms256m

Still nothing,
 

lazydog

macrumors 6502a
Sep 3, 2005
709
6
Cramlington, UK
Hi
I set the heap size all the time in Xcode and it works fine. Just do what Littleodie914 says. Add an argument for the executable, and make sure it is ticked. Just put in what the argument is, eg -Xms256m -Xmx256m. Don't use name=… value=….


b e n
 

m3the01

macrumors member
Original poster
Jun 18, 2007
70
0
Straight from the run log

[Session started at 2007-08-02 07:44:18 -0600.]
Unsupported option: -Xms256m

appletviewer has exited with status 1.


This is using the newest xcode environment 2.4.1