Xfinity malware preventing me from using browser

Discussion in 'MacBook Air' started by jwrolram, Feb 24, 2016.

  1. jwrolram macrumors newbie

    Joined:
    Feb 24, 2016
    #1
    For some reason when my Mac is connected to my house wifi it redirects me log into my xfinity account (my internet provider is centurylink and I don't have xfinity). There is an open xfinity wifi signal in my neighborhood but my Mac says it's connected to my centurylink when it redirects me to log into xfinity. I've tried resetting my browser and clearing it cookies, but outside of that I'm not sure what to do. I assume this is some kind of malware on my computer but am confused because I have no problem browsing the internet on other wifis and I have other devices that are using my houses wifi just fine. Can anyone please help?
     

    Attached Files:

  2. DeltaMac macrumors 604

    DeltaMac

    Joined:
    Jul 30, 2003
    Location:
    Delaware
    #2
    You are using Google Chrome.
    Can you change the home page in Chrome to some other site?

    Do you get the same re-direct to Xfinity activation page when you try Safari?

    What have you heard from CenturyLink, when you ask their tech support folks?

    Another possibility is that you are, in fact, not connecting to your centurylink wifi, but are connecting to a Comcast/Xfinity router.
    You can set your preferred router in System Preferences, then Network.
    Click your network card (should be the wifi network), then click the Advanced button.
    The Wifi tab will show a list of preferred networks.
    Drag your own house wifi network to the top of the list, so it would try to connect to that network first. Click OK, then click the Apply button.
     
  3. jwrolram thread starter macrumors newbie

    Joined:
    Feb 24, 2016
    #3
    I did call centurylink and the had me do everything that you listed with no result. This is what led me to believe that was an issue with malware.

     
  4. DeltaMac macrumors 604

    DeltaMac

    Joined:
    Jul 30, 2003
    Location:
    Delaware
    #4
    Not malware.
    It's just a re-direct that is completely normal, if you try to connect to an Xfinity router that has not been activated yet.

    Even if you see that activation page first - does it really affect anything?
    What I am asking is, can you just open a new page, and browse to wherever else you want?

    Can you try those things again, so you can answer the questions? - particularly:
    If that is just a "home page", or the default page that comes up when you open your browser, you should be able to change to another page, then go in to your Chrome preferences, and change the address listed for your home page.
    Do this in Chrome:
    Change your web page to something else. A page that you like will be a good choice...
    Chrome menu/Preferences.
    Under "On Startup", click Open a specific page or set of pages. Click "Set pages"
    Enter the URL for the web page that you want to use as a home page.
    Or, if you are already on THAT page (not the Comcast activation page!), then just click "Use Current Pages", then click "OK"
    That should fix you up...

    Do you get the same re-direct to the Xfinity activation web page when you try Safari?
    You can change the home page in Safari, too.
     
  5. jwrolram thread starter macrumors newbie

    Joined:
    Feb 24, 2016
    #5
    Again, I have already tried these options. Trying to open a new page was the first thing I tried but I still get redirected to the same xfinity login page. I am NOT able to browse anywhere else from the xfinity login.

    I have tried resetting the home pages in both chrome and safari and it still changes nothing.

     
  6. chrfr macrumors 603

    Joined:
    Jul 11, 2009
    #6
    This is what you get when you use Comcast/Xfinity internet and haven't registered your modem with them. It sounds like something is really a mess with your wiring and that you are somehow connected to Comcast instead of Centurylink.
     
  7. jwrolram thread starter macrumors newbie

    Joined:
    Feb 24, 2016
    #7
    I agree, is there no one who knows how to help me? I've tried turning off the wifi, forgetting both the centurylink wifi and the open xfinity one, turning on wifi, manually reconnecting to centurylink and it STILL redirects me to Comcast login.

    Did I mention that my Mac has no problem navigating the internet when tethered to my phone? What's even stranger is that other devices are able to use our centurylink connection without problem.

    I don't understand how this can be happening.

     
  8. chrfr macrumors 603

    Joined:
    Jul 11, 2009
    #8
    What happens if you turn off wifi and connect your Mac via ethernet directly to the router and directly to the modem? (This would be two separate tests.)
     
  9. DeltaMac macrumors 604

    DeltaMac

    Joined:
    Jul 30, 2003
    Location:
    Delaware
    #9
    Good to know. "Tethered to my phone" makes the phone a router, as far as your Mac is concerned, and that works because the tethered phone is not a Comcast router.
    I agree completely with chrfr post. Do you still get the re-direct if you connect directly with an ethernet cable to your home router? Make sure that you also turn OFF your wifi card. You can turn that off easily from the Wifi menu.

    You might also download and run Malwarebytes, which is a good check to help assure you that you don't have adware of some kind that you might have picked up somewhere. It's a free download, and a scan only takes a few seconds.
     
  10. Panch0 macrumors 6502a

    Joined:
    Feb 23, 2010
    Location:
    Virginia
    #10
    A couple of things that I don't see above:
    In Settings/Network, make sure the "Ask to Join" checkbox is selected - this will prevent any Open networks from being automatically joined.

    Try resetting your centurylong router to default settings and reconfiguring from there.

    Since you only have this condition when on your home WiFi, it is probably not malware on your MBA. It sounds much more like a really strange issue in your router configuration.

    What other devices are working normally on your Home Network? Wired or Wireless?
     
  11. Agent47 macrumors member

    Joined:
    Jun 11, 2014
    #11
    Try this:

    1. Flush your DNS cache:
    Open Terminal, and enter:
    sudo killall -HUP mDNSResponder

    You will need to enter the password for your user account. Restart the computer.

    2. Tell us your hardware configuration. I assume a CenturyLink ADSL2 modem, but from there what is connected to it? What kind of router?

    3. From the appearance of the page in the screen shot, it appears you are actually connecting to a XFinity activation server. What happens when you connect your MBAir to the router or modem via ethernet?
     

Share This Page