XFX ZHFC radeon 4870 reflashed, fan not working.

Discussion in 'Mac Pro' started by elsanto, Oct 23, 2009.

  1. elsanto macrumors newbie

    Joined:
    Jun 7, 2004
    #1
    I bought a 4870 ZHFC 1g model flashed it with the wonderful tutorial and rom below. This is a mac 1,1 2.8ghz with 11g ram.

    http://web.me.com/jacobcroft/4870Flash/4870Flash.html

    Everything flashed fine, rebooted and screen is gorgeous, afterfx and 3d apps are running great, BUT the fan NEVER spins up. and it gets really hot

    In bootcamp Catalyst I can go manual and have the fan run, but the temp is hitting 80c and the fan isn't running on its own.

    I've tried making my own ROM with RBE setting the lookup table significantly lower. but still no results.

    I've been toying with this for a few days and have read numerous threads but have yet to find the answer.

    any help is greatly appreciated.
    Thank you.
     
  2. MacVidCards Suspended

    Joined:
    Nov 17, 2008
    Location:
    Hollywood, CA
    #2
    80 C is normal for that card.

    90 to 100 would be bad.

    When I pull a 4870 out of my machine, the edges of the heatsink are too hot to touch.
     
  3. elsanto thread starter macrumors newbie

    Joined:
    Jun 7, 2004
    #3
    EDIT.

    I Ran GPU-Z and ati tool and hit 100c with only 2% on the fan.. any ideas?

    Thanks for the reply, I'm going to let it run a while longer and see how hot it gets, the odd thing is at 80c the fan is only running at 1%. From what i've read it should be trying to maintain a cooler temp right?

    I reflashed it with the 50C rom and it still acts like this.

    again thank you for your time.
     
  4. doccelo macrumors member

    Joined:
    Oct 10, 2009
    #4
    Do you have the stock fan or aftermarket? Did you make sure the fan's power cord was seated properly in the slot on the card? I had an issue with my card (HIS 4890) with an Accelero Twin Turbo aftermarket cooler, where I wasn't getting enough power through the card's fan power slot, and so I had to connect it directly to the molex power from the drive bays. When I had it connected to the card, the fans would spin for about 3 seconds and then stop. After I changed to molex, fans run perfectly.

    If you are running the stock cooler, have you tried to go into the Catalyst software and increase the fan speed manually? Funny thing is, when I run Catalyst (or GPU-Z) it tells me my fan is running at 2%-10%, when actually it should be reading 0% since there is no fan attached to the card's power pin and there's no way for the software to know how fast the fan is running (it runs at constant speed since it is connected directly to the molex connector).

    Just a few things to think about. Good luck.
     
  5. elsanto thread starter macrumors newbie

    Joined:
    Jun 7, 2004
    #5
    Ok, I made my own ROM again with the editor and was able to get it to run a little more to my liking by tweaking the fan settings further.. what a great tool.

    Thanks for all of the replies and suggestions. This was with the stock fan setup for future searches.
     

Share This Page