xhtml forms

Discussion in 'Web Design and Development' started by djejrejk, Jul 21, 2007.

  1. djejrejk macrumors 6502a

    djejrejk

    Joined:
    Jan 3, 2007
    Location:
    Uhh...
    #1
    Hello,

    I am having an issue with a form. I have 1 form with multiple fieldsets and 1 submit button, when i submit the form, i am only receiving the last fieldset via email, the formhandler is the Level10 php form handler. I have used the handler about 5 time with no problems and It worked great with this form until I recoded it.

    This is the basic setup of the form

    HTML:
    <form class="mavpres" method="post" action="http://something.com/form/L10Apps/L10FmX.php">
      <fieldset>
        <ol>
          <li>
             <label></label><input />
          </li>
        </ol>
      </fieldset>
    
      <fieldset>
        <ol>
          <li>
             <label></label><input />
          </li>
        </ol>
      </fieldset>
    <input type="submit" value="Submit!" name="submit" /> <input type="reset" value="reset" name="reset" />
    </form>
    
    Any thoughts?
     
  2. tominated macrumors 68000

    tominated

    Joined:
    Jul 7, 2006
    Location:
    Queensland, Australia
    #2
    you can't just have an empty input tag. you have to give it a type and name attribute at least (names shouldn't be the same)
     
  3. djejrejk thread starter macrumors 6502a

    djejrejk

    Joined:
    Jan 3, 2007
    Location:
    Uhh...
    #3
    Yeah, I know, that was just a mock up. All of the label and input tags are correct. Any other ideas?
     

Share This Page