Xmarks Safari sync

Discussion in 'OS X Mavericks (10.9)' started by Shawzborne, Jun 24, 2013.

  1. e270889o macrumors member

    Joined:
    Jul 9, 2012
    #2
    Doesn't work with auto sync but if you upload your bookmarks and download them it works perfect. I uploaded it with xmarks for chrome and then downloaded them with xmarks for safari.
     
  2. lazerbrains macrumors regular

    lazerbrains

    Joined:
    Sep 22, 2011
    #3
    I tried what you suggested, but it starts to connect, and gives me the progress bar, but then it suddenly disappears and doesn't seem to download the bookmarks. And I still can't sync. Any ideas?
     
  3. gc916 macrumors regular

    gc916

    Joined:
    Apr 23, 2012
    #4
    I submitted a support ticket to xmarks yesterday, and received the following reply:


    "Unfortunately, the latest version of Xmarks for Safari isn't compatible with Mavericks. We're actively working with Apple to resolve this problem. I have noted your email address so we can update you once a solution is available. In the meantime, are you able to sync to another Xmarks supported browser?

    We hope to update you with a solution soon. We apprecaite your patience and understanding.
    "
     
  4. lazerbrains macrumors regular

    lazerbrains

    Joined:
    Sep 22, 2011
    #5
    Thanks. Can you update here if you get a response?
     
  5. gc916 macrumors regular

    gc916

    Joined:
    Apr 23, 2012
    #6
    Sure, I'll post here if/when I hear anything further from xmarks.
     
  6. gc916 macrumors regular

    gc916

    Joined:
    Apr 23, 2012
    #7
    XMarks Safari sync has been fixed. I received the following message today from XMarks support:

    Hello,

    We appreciate your continued patience and understanding. Please follow this link to update to the latest version of Xmarks for Safari v.1.5.3: https://rodan.lastpass.com/dev/xmarks_for_safari_1.5.3.dmg

    As always, if you need additional assistance, please submit a support ticket.


    Best,
    Terry

    --
    Terry Nguyen | Marketing Specialist | LastPass.com | 571.339.5278



    I have tested the update and the sync function seems to be working as expected.
     
  7. lazerbrains macrumors regular

    lazerbrains

    Joined:
    Sep 22, 2011
  8. gc916 macrumors regular

    gc916

    Joined:
    Apr 23, 2012
  9. Regal, Nov 22, 2013
    Last edited: Nov 22, 2013

    Regal macrumors regular

    Regal

    Joined:
    Nov 7, 2010
    Location:
    Sweden
    #10
    I downloaded the last version 1.5.3 but the sync process is not working for me, it says under settings:
    "Current status: Xmarks is not running" and when i hit the sync button nothing happens..

    Anyone else having the same issue?
     
  10. gc916 macrumors regular

    gc916

    Joined:
    Apr 23, 2012
    #11
    I'm having the same problem. I have reported it to Xmarks, and I'll post their reply here.
     
  11. soloer macrumors 6502a

    soloer

    Joined:
    Sep 27, 2004
    Location:
    Omaha
    #12
    I believe the 1.5.3 version is more of a beta build and their work isn't complete yet.
     
  12. wrldwzrd89 macrumors G5

    wrldwzrd89

    Joined:
    Jun 6, 2003
    Location:
    Solon, OH
    #13
    If anyone's curious what changed in Mavericks that broke the old Xmarks, it was the removal of SyncServices. This is also the reason you can't sync info to iOS devices anymore.
     
  13. Julien macrumors G3

    Julien

    Joined:
    Jun 30, 2007
    Location:
    Atlanta
    #14
    Running 1.5.4 and it is finally syncing (on 10.9.1).

    Being so long I uploaded from Safari and replaced Bookmarks (not merged). I then opened Chrome and synced and replaced all Bookmarks. Now all Bookmarks are back in sync.
     
  14. Regal, Nov 28, 2013
    Last edited: Nov 30, 2013

    Regal macrumors regular

    Regal

    Joined:
    Nov 7, 2010
    Location:
    Sweden
    #15
    Can anyone confirm if 1.5.4 really works on safari?
     
  15. Madd the Sane macrumors 6502

    Madd the Sane

    Joined:
    Nov 8, 2010
    Location:
    Utah
    #16
    This may have something to do with iSync not working on Mavericks as well, I.E., the frameworks and APIs that Xmarks relies on have been removed.
     
  16. msvadi macrumors regular

    Joined:
    Aug 12, 2010
    #17
    Xmarks is a mess. I just stopped using it altogether. It never worked well for me anyway. For example, it constantly duplicated bookmarks.

    Safari and other browsers now can sync bookmarks across multiple devices, including iPhones and iPads. The only issue is syncing between different browsers, but I rarely see a need now to use several browsers. I'm just sticking with Safari.
     
  17. Regal macrumors regular

    Regal

    Joined:
    Nov 7, 2010
    Location:
    Sweden
    #18
    Where can i find a download window for v1.5.4?
     
  18. MaxBurn macrumors 65816

    MaxBurn

    Joined:
    Nov 25, 2010
    #19
    That does appear to be beta as they certainly haven't updated the public links yet. Hopefully they release soon?
     
  19. allan.nyholm macrumors 6502a

    allan.nyholm

    Joined:
    Nov 22, 2007
    Location:
    Aalborg, Denmark
    #20
    The above link goes all the way up to 1.5.8 if anyone's interested. Just alter the last number in the url and you'll get 1.5.8 - there is no 1.5.9 yet.

    Seemingly the DMG's all turn out the same size but the xmarks package is changing in numbers by just a small number of kilobytes.
     
  20. MaxBurn macrumors 65816

    MaxBurn

    Joined:
    Nov 25, 2010
  21. Regal macrumors regular

    Regal

    Joined:
    Nov 7, 2010
    Location:
    Sweden
    #22
    Thx for the tip allan.nyholm,

    I just tried v1.5.8 on my mbp running OS X mavericks 10.9 and it`s still not working..
     
  22. gc916 macrumors regular

    gc916

    Joined:
    Apr 23, 2012
    #23
    I agree that Xmarks is very messed up. I have uploaded/downloaded/overwritten the data on the server, repeatedly installed the beta versions, removed/uninstalled the Xmarks add-on/extensions for Safari, Firefox, and Chrome, shut down and restarted the program and my computer, and nothing makes any difference. Safari Bookmarks don't sync, and my Firefox bookmarks have completely disappeared from the browser.

    As a "premium" user, I am supposed to receive priority support, but I haven't received that. Support tickets and emails have gone unanswered. I acknowledge that LP/Xmarks doesn't have a large staff, but I don't understand how the Mavericks issue wasn't fixed during the beta period. I'm not a developer, but there are many out there who were ready for Mavericks. If they weren't going to be ready, they should have proactively notified their customers, in my opinion.

    I have been using LastPass and Xmarks for years with no trouble. I don't know what happened to Xmarks, but I'm ready to give up. I have also moved to 1Password and have been very pleased with it.
     
  23. gc916 macrumors regular

    gc916

    Joined:
    Apr 23, 2012
    #24
    Still trying to resolve the Xmarks issues. A couple of days ago, I spent about an hour cleaning up my bookmarks by logging in to Xmarks and editing My Bookmarks. I found that several duplicate "Bookmarks Menu" folders had been created. I deleted them, and arranged my bookmarks as I wanted them to appear.

    Once that was finished, I downloaded the bookmarks from the Xmarks server to each of my browsers, overwriting the previous set. That restored the correct bookmarks to each browser, although I didn't attempt to sync. In fact, I removed the Xmarks extensions from all browsers, thinking that I would need to manage bookmarks manually in the future.

    I had also reopened my support ticket with Xmarks, advising them of the ongoing sync problems. Yesterday, I received the following message:

    Running other bookmark sync extensions like Firefox Sync in addition to Xmarks is known to cause conflicts. Please disable the bookmark sync portion in Firefox Sync. Then, make sure you're running the latest version of Xmarks for your browsers: http://download.xmarks.com/download/all. Check for and disable all other bookmark sync extensions in all browsers you use to sync with Xmarks: http://helpdesk.xmarks.com/troubleshooting/duplicate-bookmarks-2/. In all instances of Firefox, delete the xmarks.sqlite file from your profile folder. Follow these steps to locate your profile folder: http://support.mozilla.org/en-US/kb/Profiles. Restart Firefox; then, retry a sync: Xmarks icon > Synchronize Now.

    If you continue to encounter sync errors, attach your new log file following the error message: https://helpdesk.xmarks.com/troubleshooting/sending-us-your-log-file/. Attach your log as a txt file or zip file.​

    I had never enabled Firefox Sync. Google Sync had been enabled, so I turned it off. I followed the steps they suggested, and downloaded the Firefox and Chrome extensions from the linked page. However, I downloaded the latest beta (v1.5.8) for Safari, as suggested in a previous post in this thread.

    As of now, all sync functions seem to be working as expected. I'll post here if I see any more problems.
     

Share This Page