XP ethernet controller driver for new Macbook?

Discussion in 'Windows, Linux & Others on the Mac' started by kdesmarais, Oct 31, 2008.

  1. kdesmarais macrumors newbie

    Joined:
    Oct 31, 2008
    #1
    Hardware Summary:

    new Macbook 13.3/2.4/CTO (Product # Z0FV)
    20GB partition for Windows XP
    Windows XP SP2 installed, then upgraded to SP3
    All Bootcamp 2.1 drivers sucessfully installed from OS X Install DVD

    I cannot get the Ethernet controller driver installed/configured on Windows XP SP3, it keeps appearing as new hardware and wants to configure the driver. Wireless network connections work fine, just having problems with direct ethernet.

    Do you know where I can download the ethernet controller driver? The one that comes with Bootcamp 2.1 does not appear to work because I installed the Broadcom XP driver that came with Bootcamp 2.1, the driver install wizard completes successfully, but in Windows Device Manager it still shows an unconfigured ethernet controller. The Broadcom chipset appears to be version BCM43XX.

    I tried shutting down Win XP and restarting, this makes no difference. I also uninstalled the ethernet controller device (from Device Manager), rebooted, reinstalled from Bootcamp 2.1 and still have the same problem.

    I have spent the past day+ searching online for the driver and/or solution to resolve this problem, but have come up emtpy. Does anyone know how to correctly get the ethernet controller driver installed?

    Thanks in advance. It is very frustrating as I cannot use a direct network connection with Windows XP (everything works fine under OS X).
     
  2. kdesmarais thread starter macrumors newbie

    Joined:
    Oct 31, 2008
    #2
    Problem Resolved!

    I was able to resolve the ethernet controller driver issue by accessing the Bootcamp within the Windows Control Panel and running the driver repair utility. It turns out that the problematic ethernet controller was not Broadcom hardware, it was in fact an NVIDIA ethernet controller. This explains why running Bootcamp's Broadcom driver installer was not solving the problem, it was going after the wrong driver...

    Once I ran the driver repair utility for Bootcamp, everything corrected itself and I can now connect my Macbook online using a wired connection with XP.
     
  3. ray.sodha macrumors newbie

    Joined:
    Nov 25, 2008
    #3
    Bootcamp driver repair utility?

    Hate to be the Newbie, but i dont know what you are talking abt!
    I just got the new Macbook and there is no driver repair utility when u run bootcamp from Windows Control Panel!!!

    Considering the same Ethernet controller problem, it'd be nice to know how to access this Driver Repair Utility!!!
     
  4. Pepee macrumors newbie

    Joined:
    Nov 26, 2008
    #4
    Hi,

    i have the same problem.installed bootcamp, formated ntfs, installed windows xp sp2, started xp and saw a lot ! ! ! ! in my hardware.... used the install dvd and some are gone, but there are still four ! left,

    like Bluetooth, VGA driver videocontroller, built in sightand networkcontroller.


    anyone know what i can do???


    greetings and thx
     
  5. BrendonThomas7 macrumors newbie

    Joined:
    Jan 21, 2009
    Location:
    San Antonio, TX
    #5
    New 2008/2009 Bootcamp Macbook Ethernet Drivers

    The suggestion to use the repair utility within Bootcamp was a good one, however, going to the Control Panel, and selecting Boot Camp does not yield the results that will lead you to a resolution.

    In this case I think something went awry with the Auto Install from the Bootcamp CD.

    I had this problem, where everything including the wireless was working, well, everything except the Ethernet Adapter. I was able to resolve my issue by manually dragging the drivers from the Apple CD Instal Disc 1 for Macbooks, and dragging the Bootcamp drivers for the Nvidia to the desktop and installing it that way.
     
  6. Mike927 macrumors newbie

    Joined:
    Oct 20, 2008
    #6
    I ran the bootcamp repair function and it has not fixed my ethernet problem. I still cant run ethernet through my macbook. I also have the new macbook using bootcamp with Sp3. Also by running the repair bootcamp it eliminated the function for my audio/brightness control.

    I check on windows xp for "add hardware" theres a yelllow question mark on the ethernet controller. Does anyone know any devices that would install the ethernet controller?
     
  7. Mike927 macrumors newbie

    Joined:
    Oct 20, 2008
    #7
    Got my ethernet problem to be fixed but now I have an audio problem. There is no audio. I popped in the mac osx CD and a red light comes out of the audio jack. I guess this is notifying that audio does not work. Audio still works in MAC OSX but not windows xp
     
  8. scmac85 macrumors newbie

    Joined:
    Nov 27, 2008
    Location:
    Charleston, SC
    #8
    I am having the same problem. All of my hardware with he exception of ethernet is working (well, kinda). In the device manager it looks like the driver is installed, but when I plug a ethernet cable in it still says an ethernet cable is unplugged.

    *my other issue is my trackpad. It goes from being too sensitive to barely working. As I typed this much of my text got deleted from my palm touching the pad, but when I click (both click and tap) it only works about every other time.
     
  9. obdave macrumors member

    Joined:
    May 25, 2008
    #9
    is there any resolution for this problem?

    I bought an MBP13 about six months ago, but I'm just now installing XP and I'm having the same issue. All the drivers seem to work, except for the 10/100/1000 ethernet adapter. It cannot detect that the network cable is plugged in. I know it's not a hardware issue because wired ethernet works fine when running OSX.

    I tried installing the drivers manually from the Apple Install DVD, that didn't work. I also Googled around and tried installing two different sets of drivers from the NVIDIA website, and that didn't work either.

    Has anyone gotten their wired ethernet to work under XP, and if so, what was the secret?
     
  10. ccannon macrumors newbie

    Joined:
    Feb 25, 2010
    #10
    I went to D:\Boot Camp\Drivers\Broadcom (where D is the Mac OS install disk)
    and doubled clicked to install: BroadcomEthernetXP and it fixed my ethernet controller device in XP
    (I was having same issue as others on this thread - it continually showed up as a new device and would give errors that the correct driver could not be found and hardware was not installed properly)
     
  11. AnAppleGirl macrumors newbie

    Joined:
    Mar 7, 2011
  12. zemsantos macrumors newbie

    zemsantos

    Joined:
    Apr 11, 2011
    Location:
    Lisbon, Portugal
    #12
    I had a similar problem with a nforce networkink controller. Macbook late 2008 (gforce9400m)

    So i went to nvidia's driver download page

    http://www.nvidia.com/Download/index.aspx?lang=en-us

    and selected:

    Product Type: nForce
    Product Series: n Force 7 series
    Product: nForce 730i/ Geforce 9400/9300
    Download Type: Driver
    Operating System: Windows XP

    And it worked for me :). The reason i choose this because it was the only one in the least with my graphics card (9400m).


    Hope it works with you. :D
     

Share This Page