XP install failed. Did I lose leopard?

Discussion in 'Windows, Linux & Others on the Mac' started by masse, Oct 20, 2008.

  1. masse macrumors 6502a

    masse

    Joined:
    May 4, 2007
    Location:
    MA/GA
    #1
    I tried to bootcamp with xp, followed the setup, xp did its initial thing, then at the first reboot I got a disk error. It would not install so I ran the cd again and reformatted the xp partition to NTFS (rather than fat32) thinking that might be the problem. Unfortunately now it still fails to boot saying

    'windows could not start because the following file is missing or corrupt: <windows root>system32\hal.dll

    Now, I can't even get back to leopard or boot from the leopard cd because I think windows overwrote the bootloader.


    Any ideas on how I can fix this to at least get leopard back?


    EDIT: Ah my hasty posting. Just got it to boot from the leopard disk, erased the windows partition, restarted from the OSX partition and it seems to be working fine again...

    But any ideas why windows xp install failed?
     
  2. Markov macrumors 6502

    Markov

    Joined:
    May 18, 2007
    Location:
    Philadelphia
    #2
    You may have some corrupted files on that disk... But that's not always the case.

    Sometimes an OS will not install because of bad RAM. OS X, Linux, and Windows all do the same thing, if you have bad RAM, installation will never complete. Try seeing if it happens with another Windows disk or try seeing if you can reinstall Leopard with no issues.

    If you can get another OS (any, just not using the same Windows Disk) then your RAM is fine.

    I believe bad HDD sectors will cause this same symptom, so get a hold of some software to make sure your hardware is ok.
     
  3. masse thread starter macrumors 6502a

    masse

    Joined:
    May 4, 2007
    Location:
    MA/GA
    #3
    Thanks a lot for your help. I repaired disk permissions, changed startup disk to my OSX partition, killed the xp partition and merged it back with the osx partition, repartitioned for XP, put in the disk and gave it another try.

    This time instead of deleting the partition that OSX made for xp (fat32), I modified it and reformatted to NTFS (like I should have done initially). It installed right the first time and everything is now flawless.

    So I guess it was a lot of panic for nothing.

    Problem solved.
     
  4. caliguy82 macrumors newbie

    Joined:
    Oct 28, 2008
    #4
    I have this same problem, but I have Tiger, therefore my boot camp is expired.

    How do I A) get back to OSX from this error message, or B) boot off of windows and try to reinstall it?

    My computer is basically frozen at the hal.dll error message and I cant get it to do anything else.

    (FYI, since my bootcamp is expired, I cant hold the option key at startup)
     
  5. JNB macrumors 604

    JNB

    Joined:
    Oct 7, 2004
    Location:
    In a Hell predominately of my own making
    #5
    Change your system clock to last year (prior to September 30, IIRC), and Boot Camp should be functional again, long enough for you to recover. Or just get Leopard.

    The hal.dll error is not uncommon, especially if the formatting & initialization process is not followed to the letter and in sequence, or if the Windows disk is OEM instead of retail, or if it was a slipstreamed SP2.

    The error will almost always be caused by and corrected in the boot.ini file. Yours should look like this, the only difference may be the partition (mine is a totally stock Boot Camped install) and the OS version:

    Code:
    [boot loader]
    timeout=30
    default=multi(0)disk(0)rdisk(0)partition(3)\WINDOWS
    [operating systems]
    multi(0)disk(0)rdisk(0)partition(3)\WINDOWS="Microsoft Windows XP Professional" /noexecute=optin /fastdetect
     
  6. Neil321 macrumors 68040

    Neil321

    Joined:
    Nov 6, 2007
    Location:
    Britain, Avatar Created By Bartelby
    #6
    JohnNotBeatle

    Caliguy82 posted this question in this thread in which i posted the same answer as you but it seems he cant get passed the error screen & wont let him boot into either OS, if you any different ideas to the ones i posted id be interested in them for future reference

    Neil
     

Share This Page