XP -> Leopard VNC disconnects as soon as I connect

Discussion in 'Mac Basics and Help' started by shoelessone, Nov 25, 2009.

  1. shoelessone macrumors 6502

    Joined:
    Jul 17, 2007
    #1
    Hi all!

    I'd like to be able to VNC to my Mac at home. Here are the steps I followed (on my Mac - latest version of Leopard)

    1) In the "sharing" control panel options I turned on Screen Sharing

    2) In the screen sharing options I set "allow VNC access with password" (or something like that) and set my password

    3) On my airport extreme I entered "manual setup" and in the port forwarding menu (I forget what it's called) I selected "remote desktop access" from the dropdown menu. That seemed to add the correct ports (5900 was one of them), and I entered my local IP address for my mac in the dialog as well.


    NOW, here are my symptoms:

    1) I used UltraVNC as well as Real VNC to try to connect to my Mac from a remote computer.

    2) I was able to connect, and I was prompted for a password. So far so good

    3) I seemed to CONNECT - a window opened that seemed to be the resolution of my Mac, and my Mac name showed up in the window bar. But the background was black (perhaps because my screen saver is on). HOWEVER

    4) I was only connected for literally half a second, before the window closed. In Ultra VNC, I got no error message. In Real VNC, I get "read: Connection reset by peer (10054).



    That's about it. I've tried googling, but I haven't had any luck.

    Thoughts? Help? This is driving me crazy!!

    <3

    Thanks all!
     
  2. Makosuke macrumors 603

    Joined:
    Aug 15, 2001
    Location:
    The Cool Part of CA, USA
    #2
    At least back in 10.4 the built-in VNC server was somewhat picky about the color depth and quality option settings (compression) of the client connecting to it. Even connecting from another Mac, if I had the setting wrong I'd get either messed up video or dropped connections like you're seeing. It was particularly unhappy if you tried to connect at a bit depth lower than what the computer was set for (though I have vague memories of that getting fixed at some point).

    Try setting a higher bit depth and experiment with different compression settings; might help.
     
  3. shoelessone thread starter macrumors 6502

    Joined:
    Jul 17, 2007
    #3
    Thanks for the thought!

    Only one issue: I just tried connecting to my computer from a local IP (within my network) and I was able to connect using Ultra VNC with basically any settings.

    So it seems to be something with the network... (I'm guessing!)

    Thanks for the help, any other ideas anybody?
     
  4. AndyR macrumors 6502a

    AndyR

    Joined:
    Dec 9, 2005
    Location:
    Auckland, New Zealand
    #4
    I know this is an old post but it helped me anyway.

    I had the exact same problem with it disconnecting from work, but being fine on my home network. Turns out VNC at work was defaulting to medium color depth, but once I set it to Full it worked fine. :D
     

Share This Page