XP on MAC:Medieval Total War crash

Discussion in 'Mac and PC Games' started by ebothma, Nov 30, 2009.

  1. ebothma macrumors newbie

    Joined:
    Jul 26, 2008
    #1
    Hi there.

    Hopefully Im writing this in the correct section. I recently bootcamped my macbook and installed all the latest bootcamp drivers for XP, 3.0 I think. I then installed an oldie but a goody, Medieval:Total War but I have the following problem;

    I can run the and play about 75% of the game. Quick battles, custom battles, historical campaign battles and even the Map Editor. The Macbook runs it very well. But I cannot access the single player campaigns or the campaign tutorials. When I select these the loading screen appears as normal but crashes back to windows when It stops loading.

    Now I have been all over the net looking for a solution and I think that I have narrowed it down to the campaign map graphics freaking out my Graphics card or something similar. I have tried the "button fix", I have installed all the latest patches for the game, I have done the "skipcredits.txt" fix and I have played around with every single performance and graphic setting in the game, matching it with the mac as I go.

    So the specs:

    Macbook 1.1, 1.8Ghz core 2duo, 1gb Ram, Intel 945 express with the GMA950 graphics chip

    Im pretty sure it's a clash with the GMA950 but surely there must be a way to fix this. I know some super bright person could write a patch because there are thousands of people with the same problem and it'll be most appreciated!!

    Thanks for all the help in advance.
    etrain
     
  2. lostime macrumors regular

    Joined:
    May 19, 2009
    #2
    How does Medieval run on the 950? I remember the NVidia 7400 in my HP laptop barely ran it.
     

Share This Page