XP SP3 Won't Install

Discussion in 'Windows, Linux & Others on the Mac' started by Dmac77, May 30, 2008.

  1. Dmac77 macrumors 68020

    Dmac77

    Joined:
    Jan 2, 2008
    Location:
    Michigan
    #1
    Hi everyone,

    I can't get XP SP3 to install, I have already installed bootcamp 2.1 under windows and I continue to get a error message along these lines "Insufficent disk space remaining. 4 more mb are needed to install." or something like that. :mad:

    This makes no sense, because I have 37GB left on the bootcamp partition.

    Anyone else having this problem? Anyone know how to fix this?

    Thanks,

    Don
     
  2. yellow Moderator emeritus

    yellow

    Joined:
    Oct 21, 2003
    Location:
    Portland, OR
    #2
    Have you installed BootCamp 2.1? Cause you need too if you're going to install SP3.

    Duh. I can read. Honest.

    So.. make sure BC is all up to date INSIDE Windows using the Apple Updater executable?
     
  3. Dmac77 thread starter macrumors 68020

    Dmac77

    Joined:
    Jan 2, 2008
    Location:
    Michigan
    #3
    all apple software is up to date on the windows partition, even the optionals like safari, itunes, quicktime.
     
  4. yellow Moderator emeritus

    yellow

    Joined:
    Oct 21, 2003
    Location:
    Portland, OR
    #4
    Did you download it directly to install, or are you trying to pull it thru Windows Update?
     
  5. Dmac77 thread starter macrumors 68020

    Dmac77

    Joined:
    Jan 2, 2008
    Location:
    Michigan
  6. oli2140 macrumors 6502

    Joined:
    Jan 13, 2008
    #6
    I have this problem as well. I reformatted my bootcamp partition recently as well.
     
  7. Moof1904 macrumors 65816

    Joined:
    May 20, 2004
    #7
    This is an incompatibility with the formatting of the bootcamp partition and the windows installer. Stand by. Someone emailed me a link to the fix yesterday. I'll dig it up...
     
  8. Dmac77 thread starter macrumors 68020

    Dmac77

    Joined:
    Jan 2, 2008
    Location:
    Michigan
    #9
    :D Thanks everyone, the directions in that link worked.:D

    Don
     
  9. akdj macrumors 65816

    akdj

    Joined:
    Mar 10, 2008
    Location:
    Alaska
    #10
    This fix is not working for me...has it worked for everyone else?

    One question, and this is probably a very dumb one...but do you need to include the parenthesis with the "BootDir" and "C:\"? Because I did not include them and am still getting the same message. I followed the regedit to the letter two times and have re-booted with the changes and have continued to get the same messages...I need 4 MB for install and uninstall...yada yada.

    Any ideas? 32 gigs of total space, 26G left, MBP 2.2 (Last year's model) with 4 Gigs or RAM, 15.4inch screen...Bootcamp with XP Home SP2.

    Thanks for the guidance!

    Jeremy
     
  10. yellow Moderator emeritus

    yellow

    Joined:
    Oct 21, 2003
    Location:
    Portland, OR
    #11
    Not parenthesis, I think. You mean double-quotes?

    Either way, no to both. :)

    HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Setup\

    And in the right pane of the "Setup" section, you put in a new string value called BootDir, and gave it the value of C:\ ?
     
  11. akdj macrumors 65816

    akdj

    Joined:
    Mar 10, 2008
    Location:
    Alaska
    #12
    Thanks yellow for the clarification...I actually didn't use the double quotes either time I tried...just wanted to make sure I wasn't supposed to.

    Otherwise, I did what you wrote and what MS says but no dice. It still comes up with same error message.

    I will try again this afternoon.

    Thanks again

    Jer

    I am an idiot...still running BC 1.4 Beta (didn't even think to check vers #). I am updating to BC 2.1 right now (mandatory for XP SP3, it says:))

    Thanks again yella

    J
     
  12. yellow Moderator emeritus

    yellow

    Joined:
    Oct 21, 2003
    Location:
    Portland, OR
    #13
    I don't think that updater will work with the beta. You'll have to use the Leopard installer disc first.
     
  13. akdj macrumors 65816

    akdj

    Joined:
    Mar 10, 2008
    Location:
    Alaska
    #14
    It's Tiger 10.4.11 I believe (Last year's MBP) with the free beta edition of BC that was on the Mac site pre-Leopard.

    It is downloading right now (about 30%) so I will let you know if it works without. I don't have the Tiger install disc with me (I am at work), so if it doesn't work, I will re-install tonight.

    2.1 works with Tiger, right? It looks like it updates all previous versions of BC from the site.

    J
     
  14. yellow Moderator emeritus

    yellow

    Joined:
    Oct 21, 2003
    Location:
    Portland, OR
    #15
    No, not Tiger. Leopard. 10.5. Don't think you can use BC2.x without having Leopard.

    That is to say.. you MUST have BC2.0 in order to update to 2.1. And in order to get 2.0, you have a Leopard installer disc with the drivers.
     
  15. akdj macrumors 65816

    akdj

    Joined:
    Mar 10, 2008
    Location:
    Alaska
    #16
    So there is NO way to get SP3 on XP without upgrading to OSX 10.5?

    It says BC 2.1 is MANDATORY for install of XP SP3.

    Deductive reasoning tells me that I must upgrade to Leopard in order to get XP SP3? That makes NO sense! Not to shoot the messenger, and certainly thanks for the tip, but that is ugly!

    No one else has had any luck with XP SP3 using the "outdated" BC versions that came free (from Mac.com) with Tiger (OSX 10.4.X)?

    J

    Actually, after reading more into it, I'm not sure you're correct Yellow.

    It says on the Boot Camp Update 2.1 for Windows XP....

    "This updated addresses issues and improves compatibility with MS Windows XP and MS Vista running on a Mac computer using Boot Camp. It is highly recommended for ALL Boot Camp Users."

    "Important: Installation of BC 2.1 is REQUIRED before installing Windows XP Service Pack 3 (SP3)"

    Are you TRULY sure I cannot use 2.1 on Tiger? I am asking because on a 40kb/s download it is taking two hours:)

    Take care,

    J
     
  16. yellow Moderator emeritus

    yellow

    Joined:
    Oct 21, 2003
    Location:
    Portland, OR
    #17
    Seems pretty likely to me.

    The Beta for Boot Camp ended. BC2.0 was included with Leopard, and only Leopard. It's not "legally" downloadable anywhere.
    In fact, the Mac side probably won't install at all w/o the OS declaring itself as Leopard. The drivers for Windows? They might work. I dunno. But you won't find "legally" them (2.0) anywhere but on a Leopard installer disc.
     
  17. akdj macrumors 65816

    akdj

    Joined:
    Mar 10, 2008
    Location:
    Alaska
    #18
    LOL...still reading and finding more out.

    Can I use my Leopard disc I have with my Mac Pro (early '08) to update my beta BC version on my MBP (2007 with Tiger)? I do see now in a very obscure, out of the way FAQ that you DO in fact need to OSX Leopard disc or "Max OSX Install Disc 1".

    Do I have these same drivers on my OSX Tiger disc?

    This is way TOOOOOO confusing. Maybe SP2 is just fine:)
     
  18. yellow Moderator emeritus

    yellow

    Joined:
    Oct 21, 2003
    Location:
    Portland, OR
    #19
    Yeah, probably. I don't think Windows XP gives a crap. :)

    Though I don't know if there's driver variations across the Leopard (Boot Camp) discs.
     
  19. akdj macrumors 65816

    akdj

    Joined:
    Mar 10, 2008
    Location:
    Alaska
    #20
    Cool, thanks for your help

    I'm not sure I want to dive any deeper as I need this computer for live shows, production and recording with Adobe Audition on the Windows side and Logic on the OSX side.

    I cannot afford to have this think go cock-eyed right now (Weddings, reunions, etc. all summer).

    I haven't had any issues with SP2 at this point (in the limited capacity that I am using it).

    J
     

Share This Page