Xquartz Clipboard

Discussion in 'Mac Apps and Mac App Store' started by sircharlo, Mar 2, 2009.

  1. sircharlo macrumors member

    Joined:
    Nov 7, 2008
    #1
    Hey all.

    I have a black Macbook with Leopard. I installed Xquartz latest version a while back, and it works like a charm. When i go in preferences, there are five tabs total, with a tab for clipboard, where i can modify options for the shared clipboard, which works great.

    I now have someone else's aluminum Macbook Pro, brand new with Leopard. I installed the latest version of X11 from Xquartz, but i still get the old preferences window (only three tabs), with no tab for shared clipboard. Now, when i go in terminal and type "defaults read org.x.x11", i see values pertaining to the clipboard, all set to zero. I can manually set them individually to 1 using the Terminal, but opening an X11 program almost immediately resets the values to zero. The settings are there, but there is no way to access them through the preferences window on the new Macbook, while on the old Macbook everything is fine.

    Here is the output of "defaults read org.x.x11":

    Code:
    defaults read org.x.x11{
        "NSWindow Frame x11_prefs" = "703 498 478 338 0 0 1440 878 ";
        "app_to_run" = "/usr/bin/true";
        "cache_fonts" = 1;
        depth = -1;
        "done_xinit_check" = 1;
        "enable_fake_buttons" = 1;
        "enable_key_equivalents" = 0;
        "enable_system_beep" = 0;
        "fullscreen_menu" = 0;
        "login_shell" = "/bin/sh";
        "no_auth" = 0;
        "nolisten_tcp" = 1;
        "sync_clipboard_to_pasteboard" = 0;
        "sync_keymap" = 0;
        "sync_pasteboard" = 0;
        "sync_pasteboard_to_clipboard" = 0;
        "sync_pasteboard_to_primary" = 0;
        "sync_primary_on_select" = 0;
        "wm_click_through" = 0;
        "wm_ffm" = 0;
        "wm_focus_on_new_window" = 0;
    }
    I'm thinking it's a file that got left behind in the update, but I would really appreciate any help you could give me.
     

    Attached Files:

  2. sircharlo thread starter macrumors member

    Joined:
    Nov 7, 2008
    #2
    I sort of fixed the problem by copying the main.nib file in the black Macbook's X11.app/Contents/Resources/English.lproj to the other Macbook's X11.app/Contents/Resources/French.lproj and English.lproj (the Mac is french, so I put it in both to be safe). Turns out the nib file is an interface file. Double-clicking it opens Interface Builder. So I basically copied the interface from my X11 to the other Mac's X11.

    The only thing that nags now is that for the shared clipboard to work, you need to open the preferences of X11 on startup... That's it. Except for that, my solution worked.

    Weird that the nib file did not get updated... Perhaps because my friend's Mac is French and the French localization of X11 is not as well supported.
     

Share This Page