Xquartz / X11 on 10.9

Discussion in 'OS X Mavericks (10.9)' started by east85, Aug 8, 2013.

  1. east85 macrumors 65816

    east85

    Joined:
    Jun 24, 2010
    #1
    I recently managed to rid my Windows 7 partition from my drive with the help of Wine/Winebottler/Xquartz. There's a program I needed specifically for work, so I just packaged it and the rest is history. I was just wondering if anyone could confirm that the X11 framework operates on 10.9. I would like to adopt 10.9 when it comes to market, but only if I can continue to run the program I need.

    Thanks.
     
  2. east85 thread starter macrumors 65816

    east85

    Joined:
    Jun 24, 2010
    #2
    Maybe by the time it comes out I will have installed a second internal SSD to test this.
     
  3. OMCS macrumors newbie

    Joined:
    Jun 25, 2013
    Location:
    London
    #3
    I can confirm that XQuartz works perfectly on Mavericks. I've used it with Wine and had no issues with it.
     
  4. nnnikt macrumors newbie

    Joined:
    Oct 2, 2013
    #4
    I've just installed 2.7.4 to get Gimp working on 10.9 dp8 and I can double confirm that it's working.
     
  5. nourani macrumors newbie

    Joined:
    Oct 22, 2013
    #5
    X11/Xquartz and MATLAB on Mavericks 10.9

    Just upgraded to 10.9 and when I try to run MATLAB I am told that I need to install X11 which Xquartz is installed and has been working :confused:

    Any ideas how I can tell MATLAB that X11 is available?
     
  6. mjlee macrumors newbie

    Joined:
    Oct 23, 2013
    #6
    I just had the exact same problem with MATLAB after running it for the first time since upgrading. All I did to fix it was reinstall XQuartz and MATLAB is now running fine.
     
  7. fredlef macrumors newbie

    Joined:
    Sep 25, 2012
    #7
    Me too but with another program. Tried reinstalling xquartz and crashes every time on install.
     
  8. bluespaceoddity macrumors regular

    Joined:
    Jun 14, 2009
    #8
    After reinstalling XQuartz things run as before.
     
  9. mystery78 macrumors newbie

    Joined:
    Oct 29, 2013
    #9
    Still doesn't work

    Matlab for us is on a server, and we often run it from the server. After
    I installed XQuartz it enables me to connect to the server and shows me matlab on this display. HOWEVER, the tunneling is not complete -- the keyboard/mouse control does not let me type/click on any GUI's from Matlab. :mad:

    Can someone help me.. spoke to apple support.. they said.. sorry we no longer support it.. you can clean install the old version and start from there..
     

Share This Page