XServe 10.6 SL Setup Assistant Fails

Discussion in 'Mac OS X Server, Xserve, and Networking' started by Koofka, Jul 28, 2010.

  1. Koofka macrumors newbie

    Mar 5, 2010
    Hello All,

    Been hacking at an XServer 2,1 (Early 2008) box for the past 18 hours or so straight attempting to do a clean reinstall from L to SL Server. Each round I have cleared (repartitioning to be certain) the system drive (raid) and performed the default install. Each time I reach the Network pane of Setup assistant it returns a fairly generic message regarding "An Error occurred. There was a problem configuring your network services. Please inspect you network settings and try again." and fails to continue.

    Currently in the Network applet I have 2 Eth interfaces (1 connected, 1 discconned) and 2 LOM interfaces and 1 Firewire and have probably tried every combination of setting interfaces to inactive / static / dhcp etc.

    From the poking I did it seems that DHCP / DNS is generally the culprit and the existing windows dns on the network was a bit of a mess. Setup a Ubuntu server in VMWare with fairly straightforward setting for both and the SL install seemed to hear and incorporate them.

    Only work around so far that I have come across is to manually set the .AppleSetupDone bit via SSH, the serial # via Server admin, and reboot past the setup assistant. Logging on with root and the 8 digit serial then works, but it seems like the machine is at least partially gimped.

    Also tried disconnecting the server from the network for the setup and alternatively isolating its port in VLAN. Tried install disks for both 10.6 and 10.6.3.

    Figured this might be a long shot, but any ideas would be greatly appreciated. Trying to muster up the strength to use an old Airport Extreme and setup a mini network for the next install try (Just based on a number of the documentation examples coupling the install with an aiport and the hope there may be some inherent compatibility gain). Then again I am probably just overtired and getting desperate.

    - Koof
  2. Koofka thread starter macrumors newbie

    Mar 5, 2010
    Additional Info

    Left the install on the Network pane overnight and returned to two error dialogs over top of it.

    "Refreshing connection" "Failed to Authenticate to the server"
    "Getting network interfaces" "Failed to authenticate to the server"

    Had read some posts on the install acting wonky under 10.6.2 and seeing two ethernet instances on the same server as a serial number violation. But the installs I had attempted shouldn't have been 10.6.2 (10.6 and 10.6.3). And I had left the second adapter disconnected on each install so far. The install is trying to create an LOM interface on both adapters as well.

    To note, this is a newly purchased SL Server install kit and the serial is completely legit and unused previously.

  3. Koofka thread starter macrumors newbie

    Mar 5, 2010
    Seems to be an LOM problem

    Lo all-

    Been working on this for the better part of a week and I think I have tracked down the SL Setup Assistant issue to a fubared LOM interface that was failing to accept the commands issued at the Network panel. Arrived at this via manually touching the .AppleSetupDone bit via ssh and manually configuring the server. Throughout the LOM interface was unavailable to configure via Server Monitor and, although the Software Update identified it need the 1.2 firmware update, once downloaded - applying the updated would fail. Via ipmitool I attempted a cold reset of the LOM interface which apparently disabled the chip entirely. Subsequent reboots would show LOM revision as 'Unavailable' via system profiler. Tracked down the powering off reset for LOM via forum posts and this successfully restored the LOM to its visible (via System Profiler) but non functional / non updateable state.

    So arrived at the theory that the LOM interface was the cause of the SL assistant failing to pass the Network prompt. Continued manually tweaking the server but mangled my Open Directory setup enough that I wanted to perform a clean SL install again. Used the ipmitool mc reset cold to disable the interface with the idea that this would allow me to complete the SL assistant, but instead it fails at the initial screen of the assistant while "configuring network interfaces". Now the power down process to reinitialize the LOM does not appear to function and it continues to appear as Unavailable via the system profiler. All calls I have tried from ipmitool fail with hexidecimal errors.

    In the process of completing a run through the EFI Apple Server Diagnostics looking for any hardware errors, but so far clean as it churns through the more complex memory tests.

    Any idea on other means for trying to get the LOM up and functioning correctly would be greatly appreciated. Have done a good deal of looking and the standard documented approaches do not appear to be working.

    Thanks for reading.


Share This Page